Login
Newsletter
Werbung

Sicherheit: Denial of Service in gstreamer-rtsp-server
Aktuelle Meldungen Distributionen
Name: Denial of Service in gstreamer-rtsp-server
ID: openSUSE-SU-2020:0535-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1, SUSE openSUSE Backports SLE-15-SP1
Datum: Fr, 17. April 2020, 23:12
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-6095
Applikationen: gstreamer-rtsp-server

Originalnachricht

   openSUSE Security Update: Security update for gstreamer-rtsp-server
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0535-1
Rating: moderate
References: #1168026
Cross-References: CVE-2020-6095
Affected Products:
openSUSE Leap 15.1
openSUSE Backports SLE-15-SP1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for gstreamer-rtsp-server fixes the following issues:

- CVE-2020-6095: Fixed a NULL pointer dereference when handling an invalid
basic Authorization header (boo#1168026).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-535=1

- openSUSE Backports SLE-15-SP1:

zypper in -t patch openSUSE-2020-535=1



Package List:

- openSUSE Leap 15.1 (x86_64):

gstreamer-rtsp-server-debuginfo-1.12.5-lp151.3.3.1
gstreamer-rtsp-server-debugsource-1.12.5-lp151.3.3.1
gstreamer-rtsp-server-devel-1.12.5-lp151.3.3.1
gstreamer-rtsp-server-devel-debuginfo-1.12.5-lp151.3.3.1
libgstrtspserver-1_0-0-1.12.5-lp151.3.3.1
libgstrtspserver-1_0-0-debuginfo-1.12.5-lp151.3.3.1
typelib-1_0-GstRtspServer-1_0-1.12.5-lp151.3.3.1

- openSUSE Backports SLE-15-SP1 (aarch64 ppc64le s390x x86_64):

gstreamer-rtsp-server-devel-1.12.5-bp151.4.3.1
libgstrtspserver-1_0-0-1.12.5-bp151.4.3.1
typelib-1_0-GstRtspServer-1_0-1.12.5-bp151.4.3.1


References:

https://www.suse.com/security/cve/CVE-2020-6095.html
https://bugzilla.suse.com/1168026

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung