Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in webkit2gtk3
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in webkit2gtk3
ID: openSUSE-SU-2020:0602-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Sa, 2. Mai 2020, 19:16
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10018
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-11793
Applikationen: webkit2gtk3

Originalnachricht

   openSUSE Security Update: Security update for webkit2gtk3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0602-1
Rating: important
References: #1165528 #1169658
Cross-References: CVE-2020-10018 CVE-2020-11793
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for webkit2gtk3 to version 2.28.1 fixes the following issues:

Security issues fixed:

- CVE-2020-10018: Fixed a denial of service because the
m_deferredFocusedNodeChange data structure was mishandled (bsc#1165528).
- CVE-2020-11793: Fixed a potential arbitrary code execution caused by a
use-after-free vulnerability (bsc#1169658).

Non-security issues fixed:

- Add API to enable Process Swap on (Cross-site) Navigation.
- Add user messages API for the communication with the web extension.
- Add support for same-site cookies.
- Service workers are enabled by default.
- Add support for Pointer Lock API.
- Add flatpak sandbox support.
- Make ondemand hardware acceleration policy never leave accelerated
compositing mode.
- Always use a light theme for rendering form controls.
- Add about:gpu to show information about the graphics stack.

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-602=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libjavascriptcoregtk-4_0-18-2.28.1-lp151.2.15.2
libjavascriptcoregtk-4_0-18-debuginfo-2.28.1-lp151.2.15.2
libwebkit2gtk-4_0-37-2.28.1-lp151.2.15.2
libwebkit2gtk-4_0-37-debuginfo-2.28.1-lp151.2.15.2
typelib-1_0-JavaScriptCore-4_0-2.28.1-lp151.2.15.2
typelib-1_0-WebKit2-4_0-2.28.1-lp151.2.15.2
typelib-1_0-WebKit2WebExtension-4_0-2.28.1-lp151.2.15.2
webkit-jsc-4-2.28.1-lp151.2.15.2
webkit-jsc-4-debuginfo-2.28.1-lp151.2.15.2
webkit2gtk-4_0-injected-bundles-2.28.1-lp151.2.15.2
webkit2gtk-4_0-injected-bundles-debuginfo-2.28.1-lp151.2.15.2
webkit2gtk3-debugsource-2.28.1-lp151.2.15.2
webkit2gtk3-devel-2.28.1-lp151.2.15.2
webkit2gtk3-minibrowser-2.28.1-lp151.2.15.2
webkit2gtk3-minibrowser-debuginfo-2.28.1-lp151.2.15.2

- openSUSE Leap 15.1 (noarch):

libwebkit2gtk3-lang-2.28.1-lp151.2.15.2

- openSUSE Leap 15.1 (x86_64):

libjavascriptcoregtk-4_0-18-32bit-2.28.1-lp151.2.15.2
libjavascriptcoregtk-4_0-18-32bit-debuginfo-2.28.1-lp151.2.15.2
libwebkit2gtk-4_0-37-32bit-2.28.1-lp151.2.15.2
libwebkit2gtk-4_0-37-32bit-debuginfo-2.28.1-lp151.2.15.2


References:

https://www.suse.com/security/cve/CVE-2020-10018.html
https://www.suse.com/security/cve/CVE-2020-11793.html
https://bugzilla.suse.com/1165528
https://bugzilla.suse.com/1169658

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung