Login
Newsletter
Werbung

Sicherheit: Denial of Service in openldap2
Aktuelle Meldungen Distributionen
Name: Denial of Service in openldap2
ID: openSUSE-SU-2020:0647-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Mo, 11. Mai 2020, 12:48
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12243
Applikationen: OpenLDAP

Originalnachricht

   openSUSE Security Update: Security update for openldap2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0647-1
Rating: important
References: #1170771
Cross-References: CVE-2020-12243
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for openldap2 fixes the following issues:

- CVE-2020-12243: Fixed a denial of service related to recursive filters
(bsc#1170771).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-647=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

libldap-2_4-2-2.4.46-lp151.10.9.1
libldap-2_4-2-debuginfo-2.4.46-lp151.10.9.1
openldap2-2.4.46-lp151.10.9.1
openldap2-back-meta-2.4.46-lp151.10.9.1
openldap2-back-meta-debuginfo-2.4.46-lp151.10.9.1
openldap2-back-perl-2.4.46-lp151.10.9.1
openldap2-back-perl-debuginfo-2.4.46-lp151.10.9.1
openldap2-back-sock-2.4.46-lp151.10.9.1
openldap2-back-sock-debuginfo-2.4.46-lp151.10.9.1
openldap2-back-sql-2.4.46-lp151.10.9.1
openldap2-back-sql-debuginfo-2.4.46-lp151.10.9.1
openldap2-client-2.4.46-lp151.10.9.1
openldap2-client-debuginfo-2.4.46-lp151.10.9.1
openldap2-contrib-2.4.46-lp151.10.9.1
openldap2-contrib-debuginfo-2.4.46-lp151.10.9.1
openldap2-debuginfo-2.4.46-lp151.10.9.1
openldap2-debugsource-2.4.46-lp151.10.9.1
openldap2-devel-2.4.46-lp151.10.9.1
openldap2-devel-static-2.4.46-lp151.10.9.1
openldap2-ppolicy-check-password-1.2-lp151.10.9.1
openldap2-ppolicy-check-password-debuginfo-1.2-lp151.10.9.1

- openSUSE Leap 15.1 (x86_64):

libldap-2_4-2-32bit-2.4.46-lp151.10.9.1
libldap-2_4-2-32bit-debuginfo-2.4.46-lp151.10.9.1
openldap2-devel-32bit-2.4.46-lp151.10.9.1

- openSUSE Leap 15.1 (noarch):

libldap-data-2.4.46-lp151.10.9.1
openldap2-doc-2.4.46-lp151.10.9.1


References:

https://www.suse.com/security/cve/CVE-2020-12243.html
https://bugzilla.suse.com/1170771

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung