Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in LibVNCServer
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in LibVNCServer
ID: openSUSE-SU-2020:0624-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Mo, 11. Mai 2020, 13:26
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15681
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-20788
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15690
Applikationen: LibVNCServer

Originalnachricht

   openSUSE Security Update: Security update for LibVNCServer
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0624-1
Rating: important
References: #1155419 #1160471 #1170441
Cross-References: CVE-2019-15681 CVE-2019-15690 CVE-2019-20788

Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for LibVNCServer fixes the following issues:

- CVE-2019-15690: Fixed a heap buffer overflow (bsc#1160471).
- CVE-2019-15681: Fixed a memory leak which could have allowed to a remote
attacker to read stack memory (bsc#1155419).
- CVE-2019-20788: Fixed a integer overflow and heap-based buffer overflow
via a large height or width value (bsc#1170441).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-624=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

LibVNCServer-debugsource-0.9.10-lp151.7.3.1
LibVNCServer-devel-0.9.10-lp151.7.3.1
libvncclient0-0.9.10-lp151.7.3.1
libvncclient0-debuginfo-0.9.10-lp151.7.3.1
libvncserver0-0.9.10-lp151.7.3.1
libvncserver0-debuginfo-0.9.10-lp151.7.3.1


References:

https://www.suse.com/security/cve/CVE-2019-15681.html
https://www.suse.com/security/cve/CVE-2019-15690.html
https://www.suse.com/security/cve/CVE-2019-20788.html
https://bugzilla.suse.com/1155419
https://bugzilla.suse.com/1160471
https://bugzilla.suse.com/1170441

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung