Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in python-rpyc
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in python-rpyc
ID: openSUSE-SU-2020:0685-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Sa, 23. Mai 2020, 13:56
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-16328
Applikationen: python-rpyc

Originalnachricht

   openSUSE Security Update: Security update for python-rpyc
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0685-1
Rating: moderate
References: #1152987
Cross-References: CVE-2019-16328
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for python-rpyc to 4.1.5 fixes the following issues:

Security issue fixed:

- CVE-2019-16328: Fixed a missing protocol security check that could have
led to code execution (boo#1152987).


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-685=1



Package List:

- openSUSE Leap 15.1 (noarch):

python2-rpyc-4.1.5-lp151.3.3.1
python3-rpyc-4.1.5-lp151.3.3.1


References:

https://www.suse.com/security/cve/CVE-2019-16328.html
https://bugzilla.suse.com/1152987

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung