Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in dovecot23
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in dovecot23
ID: openSUSE-SU-2020:0720-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Di, 26. Mai 2020, 15:43
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10967
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10957
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10958
Applikationen: dovecot

Originalnachricht

   openSUSE Security Update: Security update for dovecot23
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0720-1
Rating: important
References: #1171456 #1171457 #1171458
Cross-References: CVE-2020-10957 CVE-2020-10958 CVE-2020-10967

Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

This update for dovecot23 to 2.3.10 fixes the following issues:

Security issues fixed:

- CVE-2020-10957: Fixed a crash caused by malformed NOOP commands
(bsc#1171457).
- CVE-2020-10958: Fixed a use-after-free when receiving too many newlines
(bsc#1171458).
- CVE-2020-10967: Fixed a crash in the lmtp and submission components
caused by mails with empty quoted localparts (bsc#1171456).

Non-security issues fixed:

- The update to 2.3.10 fixes several bugs. Please refer to
https://dovecot.org/doc/NEWS for a complete list of changes.

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-720=1



Package List:

- openSUSE Leap 15.1 (x86_64):

dovecot23-2.3.10-lp151.2.9.1
dovecot23-backend-mysql-2.3.10-lp151.2.9.1
dovecot23-backend-mysql-debuginfo-2.3.10-lp151.2.9.1
dovecot23-backend-pgsql-2.3.10-lp151.2.9.1
dovecot23-backend-pgsql-debuginfo-2.3.10-lp151.2.9.1
dovecot23-backend-sqlite-2.3.10-lp151.2.9.1
dovecot23-backend-sqlite-debuginfo-2.3.10-lp151.2.9.1
dovecot23-debuginfo-2.3.10-lp151.2.9.1
dovecot23-debugsource-2.3.10-lp151.2.9.1
dovecot23-devel-2.3.10-lp151.2.9.1
dovecot23-fts-2.3.10-lp151.2.9.1
dovecot23-fts-debuginfo-2.3.10-lp151.2.9.1
dovecot23-fts-lucene-2.3.10-lp151.2.9.1
dovecot23-fts-lucene-debuginfo-2.3.10-lp151.2.9.1
dovecot23-fts-solr-2.3.10-lp151.2.9.1
dovecot23-fts-solr-debuginfo-2.3.10-lp151.2.9.1
dovecot23-fts-squat-2.3.10-lp151.2.9.1
dovecot23-fts-squat-debuginfo-2.3.10-lp151.2.9.1


References:

https://www.suse.com/security/cve/CVE-2020-10957.html
https://www.suse.com/security/cve/CVE-2020-10958.html
https://www.suse.com/security/cve/CVE-2020-10967.html
https://bugzilla.suse.com/1171456
https://bugzilla.suse.com/1171457
https://bugzilla.suse.com/1171458

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung