Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in MozillaThunderbird
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in MozillaThunderbird
ID: openSUSE-SU-2020:0799-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Fr, 12. Juni 2020, 23:50
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12406
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12405
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12398
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-12410
Applikationen: Mozilla Thunderbird

Originalnachricht

   openSUSE Security Update: Security update for MozillaThunderbird
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0799-1
Rating: important
References: #1172402
Cross-References: CVE-2020-12398 CVE-2020-12405 CVE-2020-12406
CVE-2020-12410
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for MozillaThunderbird fixes the following issues:

Mozilla Thunderbird 68.9.0 (bsc#1172402)

- CVE-2020-12405: Fixed a use-after-free in SharedWorkerService.
- CVE-2020-12406: Fixed a JavaScript Type confusion with NativeTypes.
- CVE-2020-12410: Fixed multiple memory safety issues
- CVE-2020-12398: Fixed a potential information leak due to security
downgrade with IMAP STARTTLS
- Use a symbolic icon from branding internals

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-799=1



Package List:

- openSUSE Leap 15.1 (x86_64):

MozillaThunderbird-68.9.0-lp151.2.41.1
MozillaThunderbird-debuginfo-68.9.0-lp151.2.41.1
MozillaThunderbird-debugsource-68.9.0-lp151.2.41.1
MozillaThunderbird-translations-common-68.9.0-lp151.2.41.1
MozillaThunderbird-translations-other-68.9.0-lp151.2.41.1


References:

https://www.suse.com/security/cve/CVE-2020-12398.html
https://www.suse.com/security/cve/CVE-2020-12405.html
https://www.suse.com/security/cve/CVE-2020-12406.html
https://www.suse.com/security/cve/CVE-2020-12410.html
https://bugzilla.suse.com/1172402

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung