Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in Nokogiri
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in Nokogiri
ID: 202006-05
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Sa, 13. Juni 2020, 07:51
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2019-5477
https://github.com/sparklemotion/nokogiri/issues/1915
Applikationen: Nokogiri

Originalnachricht


--yVhtmJPUSI46BTXb
Content-Type: text/plain; charset=utf-8
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202006-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Nokogiri: Command injection
Date: June 13, 2020
Bugs: #691974
ID: 202006-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Nokogiri has a vulnerability allowing arbitrary execution of code if a
certain function is used.

Background
==========

Nokogiri is an HTML, XML, SAX, and Reader parser.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-ruby/nokogiri < 1.10.4 >= 1.10.4

Description
===========

A command injection vulnerability in Nokogiri allows commands to be
executed in a subprocess by Ruby's Kernel.open method. Processes are
vulnerable only if the undocumented method
Nokogiri::CSS::Tokenizer#load_file is being passed untrusted user
input.

Impact
======

A remote attacker could possibly execute arbitrary code with the
privileges of the process.

Workaround
==========

Avoid calling the undocumented method
Nokogiri::CSS::Tokenizer#load_file with untrusted user input.

Resolution
==========

All Nokogiri users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-ruby/nokogiri-1.10.4"

References
==========

[ 1 ] CVE-2019-5477
https://nvd.nist.gov/vuln/detail/CVE-2019-5477
[ 2 ] Upstream bug
https://github.com/sparklemotion/nokogiri/issues/1915

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202006-05

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

--yVhtmJPUSI46BTXb
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEEDA48qNrrn8VVVcst4yp5f7HQy3AFAl7kJssACgkQ4yp5f7HQ
y3BuDwf5AWAKxOfi1SGLNl3LTHO9L1x405Znig9A7CVwxA+muAvpf4rUmZwxe4I5
qPKxR/DzlcXcnuWzK1OZkBhtQfS0o1mk/aEgvXPzh4nN1EqkcbRaxdDBl4QxXS3p
6Nd+FHCCoT+k+PS5XovfCH2RchhIgfupc3XxCTNdKVTU7Tj/qxAgTzL6PChL6+Pv
NRoCUCLpDrL612fkAj6+ObjFC8zct0ZzjmxA1raoo1W65kjTKm+JDkz2H3avEQVt
YCnKxklgFrakBXYxlUVDNVwJq6I0YZsN5s+1VR9o8mMa6+NRNBfJYu+ctFvNm0+t
/74FQxeXZMkdSUreY2dSPwziDmAQjA==
=MKxF
-----END PGP SIGNATURE-----

--yVhtmJPUSI46BTXb--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung