Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in WebKitGTK+
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in WebKitGTK+
ID: 202006-08
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Sa, 13. Juni 2020, 07:52
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2020-3900
https://nvd.nist.gov/vuln/detail/CVE-2020-3902
https://nvd.nist.gov/vuln/detail/CVE-2020-3901
https://nvd.nist.gov/vuln/detail/CVE-2020-10018
https://nvd.nist.gov/vuln/detail/CVE-2020-3895
https://nvd.nist.gov/vuln/detail/CVE-2020-11793
https://nvd.nist.gov/vuln/detail/CVE-2020-3899
https://nvd.nist.gov/vuln/detail/CVE-2020-3885
https://nvd.nist.gov/vuln/detail/CVE-2020-3897
https://nvd.nist.gov/vuln/detail/CVE-2020-3894
Applikationen: WebKitGTK+

Originalnachricht


--kbCYTQG2MZjuOjyn
Content-Type: text/plain; charset=utf-8
Content-Disposition: inlin
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202006-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: WebKitGTK+: Multiple vulnerabilities
Date: June 13, 2020
Bugs: #712260
ID: 202006-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in WebKitGTK+, the worst of
which could result in the arbitrary execution of code.

Background
==========

WebKitGTK+ is a full-featured port of the WebKit rendering engine,
suitable for projects requiring any kind of web integration, from
hybrid HTML/CSS applications to full-fledged web browsers.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-libs/webkit-gtk < 2.28.2 >= 2.28.2

Description
===========

Multiple vulnerabilities have been discovered in WebKitGTK+. Please
review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All WebKitGTK+ users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-libs/webkit-gtk-2.28.2"

References
==========

[ 1 ] CVE-2020-10018
https://nvd.nist.gov/vuln/detail/CVE-2020-10018
[ 2 ] CVE-2020-10018
https://nvd.nist.gov/vuln/detail/CVE-2020-10018
[ 3 ] CVE-2020-11793
https://nvd.nist.gov/vuln/detail/CVE-2020-11793
[ 4 ] CVE-2020-11793
https://nvd.nist.gov/vuln/detail/CVE-2020-11793
[ 5 ] CVE-2020-3885
https://nvd.nist.gov/vuln/detail/CVE-2020-3885
[ 6 ] CVE-2020-3894
https://nvd.nist.gov/vuln/detail/CVE-2020-3894
[ 7 ] CVE-2020-3895
https://nvd.nist.gov/vuln/detail/CVE-2020-3895
[ 8 ] CVE-2020-3897
https://nvd.nist.gov/vuln/detail/CVE-2020-3897
[ 9 ] CVE-2020-3899
https://nvd.nist.gov/vuln/detail/CVE-2020-3899
[ 10 ] CVE-2020-3900
https://nvd.nist.gov/vuln/detail/CVE-2020-3900
[ 11 ] CVE-2020-3901
https://nvd.nist.gov/vuln/detail/CVE-2020-3901
[ 12 ] CVE-2020-3902
https://nvd.nist.gov/vuln/detail/CVE-2020-3902

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202006-08

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

--kbCYTQG2MZjuOjyn
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEEDA48qNrrn8VVVcst4yp5f7HQy3AFAl7kLucACgkQ4yp5f7HQ
y3AyrggAkcqde5du55SfxzPVnGIx/Vn6Rsz3RjjC35+SqnbHkgmNhPNK3miqe4B9
fTTcfZhQnbgHGxgCbsQNJ0cjvH/RXBxFMcwREwe28LK3/DOSLcSl9L24uAWhwpE9
6erbFsBmR68+pda3nEmNwgsBR/OLopDkriqnwfIZq+eZlGoxze6KJW0D29D21NBT
m0JKg0MAZlU9dHgzg3Xozijx0rDxXLhB4MG17NdjjrGFvdxfeJ0SlGAvf+uZ5ySh
I10ef9LeiXvOpWYp0Bw6wzjHWDwShWJyiVoaApzkGv9tVpQfkZLvp+VXzJtYtjS4
0HV/CYvMAKKyQ+BqA5sTV+rkRDVbSg==
=6f/E
-----END PGP SIGNATURE-----

--kbCYTQG2MZjuOjyn--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung