Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in adns
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in adns
ID: openSUSE-SU-2020:0827-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Do, 18. Juni 2020, 08:17
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9107
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9109
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9108
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9106
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9104
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9103
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-9105
Applikationen: adns

Originalnachricht

   openSUSE Security Update: Security update for adns
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0827-1
Rating: important
References: #1172265
Cross-References: CVE-2017-9103 CVE-2017-9104 CVE-2017-9105
CVE-2017-9106 CVE-2017-9107 CVE-2017-9108
CVE-2017-9109
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes 7 vulnerabilities is now available.

Description:

This update for adns fixes the following issues:

- CVE-2017-9103,CVE-2017-9104,CVE-2017-9105,CVE-2017-9109: Fixed an issue
in local recursive resolver which could have led to remote code
execution (bsc#1172265).
- CVE-2017-9106: Fixed an issue with upstream DNS data sources which could
have led to denial of service (bsc#1172265).
- CVE-2017-9107: Fixed an issue when quering domain names which could have
led to denial of service (bsc#1172265).
- CVE-2017-9108: Fixed an issue which could have led to denial of service
(bsc#1172265).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-827=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

adns-1.5.1-lp151.3.3.1
adns-debuginfo-1.5.1-lp151.3.3.1
adns-debugsource-1.5.1-lp151.3.3.1
libadns-devel-1.5.1-lp151.3.3.1
libadns1-1.5.1-lp151.3.3.1
libadns1-debuginfo-1.5.1-lp151.3.3.1

- openSUSE Leap 15.1 (x86_64):

libadns-devel-32bit-1.5.1-lp151.3.3.1
libadns1-32bit-1.5.1-lp151.3.3.1
libadns1-32bit-debuginfo-1.5.1-lp151.3.3.1


References:

https://www.suse.com/security/cve/CVE-2017-9103.html
https://www.suse.com/security/cve/CVE-2017-9104.html
https://www.suse.com/security/cve/CVE-2017-9105.html
https://www.suse.com/security/cve/CVE-2017-9106.html
https://www.suse.com/security/cve/CVE-2017-9107.html
https://www.suse.com/security/cve/CVE-2017-9108.html
https://www.suse.com/security/cve/CVE-2017-9109.html
https://bugzilla.suse.com/1172265

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung