Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in libgxps
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in libgxps
ID: SUSE-SU-2020:1687-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12-SP4, SUSE Linux Enterprise Software Development Kit 12-SP4, SUSE Linux Enterprise Server 12-SP5, SUSE Linux Enterprise Software Development Kit 12-SP5
Datum: Sa, 20. Juni 2020, 15:52
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-10733
Applikationen: libgxps

Originalnachricht


SUSE Security Update: Security update for libgxps
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:1687-1
Rating: moderate
References: #1092125
Cross-References: CVE-2018-10733
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP5
SUSE Linux Enterprise Software Development Kit 12-SP4
SUSE Linux Enterprise Server 12-SP5
SUSE Linux Enterprise Server 12-SP4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for libgxps fixes the following issues:

- CVE-2018-10733: Fixed a heap-based buffer over-read issue in
ft_font_face_hash (bsc#1092125).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP5:

zypper in -t patch SUSE-SLE-SDK-12-SP5-2020-1687=1

- SUSE Linux Enterprise Software Development Kit 12-SP4:

zypper in -t patch SUSE-SLE-SDK-12-SP4-2020-1687=1

- SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-1687=1

- SUSE Linux Enterprise Server 12-SP4:

zypper in -t patch SUSE-SLE-SERVER-12-SP4-2020-1687=1



Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le
s390x x86_64):

libgxps-debugsource-0.2.2-10.3.5
libgxps-devel-0.2.2-10.3.5
typelib-1_0-GXPS-0_1-0.2.2-10.3.5

- SUSE Linux Enterprise Software Development Kit 12-SP4 (aarch64 ppc64le
s390x x86_64):

libgxps-debugsource-0.2.2-10.3.5
libgxps-devel-0.2.2-10.3.5
typelib-1_0-GXPS-0_1-0.2.2-10.3.5

- SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

libgxps-debugsource-0.2.2-10.3.5
libgxps2-0.2.2-10.3.5
libgxps2-debuginfo-0.2.2-10.3.5

- SUSE Linux Enterprise Server 12-SP4 (aarch64 ppc64le s390x x86_64):

libgxps-debugsource-0.2.2-10.3.5
libgxps2-0.2.2-10.3.5
libgxps2-debuginfo-0.2.2-10.3.5


References:

https://www.suse.com/security/cve/CVE-2018-10733.html
https://bugzilla.suse.com/1092125

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung