Login
Newsletter
Werbung

Sicherheit: Zahlenüberlauf in libjpeg-turbo
Aktuelle Meldungen Distributionen
Name: Zahlenüberlauf in libjpeg-turbo
ID: SUSE-SU-2019:2971-2
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1, SUSE Linux Enterprise Module for Desktop Applications 15-SP2, SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2
Datum: Mo, 6. Juli 2020, 21:14
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-2201
Applikationen: libjpeg-turbo

Originalnachricht


SUSE Security Update: Security update for libjpeg-turbo
______________________________________________________________________________

Announcement ID: SUSE-SU-2019:2971-2
Rating: important
References: #1156402
Cross-References: CVE-2019-2201
Affected Products:
SUSE Linux Enterprise Module for Packagehub Subpackages
15-SP2
SUSE Linux Enterprise Module for Packagehub Subpackages
15-SP1
SUSE Linux Enterprise Module for Desktop Applications
15-SP2
SUSE Linux Enterprise Module for Basesystem 15-SP2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for libjpeg-turbo fixes the following issues:

- CVE-2019-2201: Several integer overflow issues and subsequent segfaults
occurred in libjpeg-turbo, when attempting to compress or decompress
gigapixel images. [bsc#1156402]


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2:

zypper in -t patch
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2020-1847=1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1:

zypper in -t patch
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-1847=1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP2:

zypper in -t patch
SUSE-SLE-Module-Desktop-Applications-15-SP2-2020-1847=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2020-1847=1



Package List:

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2 (aarch64
ppc64le s390x x86_64):

libjpeg-turbo-1.5.3-5.12.1
libjpeg-turbo-debuginfo-1.5.3-5.12.1
libjpeg-turbo-debugsource-1.5.3-5.12.1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP1 (aarch64
ppc64le s390x x86_64):

libjpeg-turbo-1.5.3-5.12.1
libjpeg-turbo-debuginfo-1.5.3-5.12.1
libjpeg-turbo-debugsource-1.5.3-5.12.1

- SUSE Linux Enterprise Module for Desktop Applications 15-SP2 (x86_64):

libjpeg8-32bit-8.1.2-5.12.1
libjpeg8-32bit-debuginfo-8.1.2-5.12.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 ppc64le s390x
x86_64):

libjpeg62-62.2.0-5.12.1
libjpeg62-debuginfo-62.2.0-5.12.1
libjpeg62-devel-62.2.0-5.12.1
libjpeg8-8.1.2-5.12.1
libjpeg8-debuginfo-8.1.2-5.12.1
libjpeg8-devel-8.1.2-5.12.1
libturbojpeg0-8.1.2-5.12.1
libturbojpeg0-debuginfo-8.1.2-5.12.1


References:

https://www.suse.com/security/cve/CVE-2019-2201.html
https://bugzilla.suse.com/1156402

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung