Login
Newsletter
Werbung

Sicherheit: Denial of Service in python3
Aktuelle Meldungen Distributionen
Name: Denial of Service in python3
ID: openSUSE-SU-2020:0940-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.2
Datum: Di, 7. Juli 2020, 07:33
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14422
Applikationen: Python

Originalnachricht

   openSUSE Security Update: Security update for python3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0940-1
Rating: important
References: #1173274
Cross-References: CVE-2020-14422
Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for python3 fixes the following issues:

- CVE-2020-14422: Fixed an improper computation of hash values in the
IPv4Interface and IPv6Interface could have led to denial of service
(bsc#1173274).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-940=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

libpython3_6m1_0-3.6.10-lp152.4.3.1
libpython3_6m1_0-debuginfo-3.6.10-lp152.4.3.1
python3-3.6.10-lp152.4.3.1
python3-base-3.6.10-lp152.4.3.1
python3-base-debuginfo-3.6.10-lp152.4.3.1
python3-base-debugsource-3.6.10-lp152.4.3.1
python3-curses-3.6.10-lp152.4.3.1
python3-curses-debuginfo-3.6.10-lp152.4.3.1
python3-dbm-3.6.10-lp152.4.3.1
python3-dbm-debuginfo-3.6.10-lp152.4.3.1
python3-debuginfo-3.6.10-lp152.4.3.1
python3-debugsource-3.6.10-lp152.4.3.1
python3-devel-3.6.10-lp152.4.3.1
python3-devel-debuginfo-3.6.10-lp152.4.3.1
python3-idle-3.6.10-lp152.4.3.1
python3-testsuite-3.6.10-lp152.4.3.1
python3-testsuite-debuginfo-3.6.10-lp152.4.3.1
python3-tk-3.6.10-lp152.4.3.1
python3-tk-debuginfo-3.6.10-lp152.4.3.1
python3-tools-3.6.10-lp152.4.3.1

- openSUSE Leap 15.2 (x86_64):

libpython3_6m1_0-32bit-3.6.10-lp152.4.3.1
libpython3_6m1_0-32bit-debuginfo-3.6.10-lp152.4.3.1
python3-32bit-3.6.10-lp152.4.3.1
python3-32bit-debuginfo-3.6.10-lp152.4.3.1
python3-base-32bit-3.6.10-lp152.4.3.1
python3-base-32bit-debuginfo-3.6.10-lp152.4.3.1

- openSUSE Leap 15.2 (noarch):

python3-doc-3.6.10-lp152.4.3.1


References:

https://www.suse.com/security/cve/CVE-2020-14422.html
https://bugzilla.suse.com/1173274

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung