Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in Tikiwiki
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Tikiwiki
ID: 200606-29
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Do, 29. Juni 2006, 07:07
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3047
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3048
Applikationen: Tikiwiki

Originalnachricht

--nextPart7254225.Y6lKhQ1C1R
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200606-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Tikiwiki: SQL injection and multiple XSS vulnerabilities
Date: June 29, 2006
Bugs: #136723, #134483
ID: 200606-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An SQL injection vulnerability and multiple XSS vulnerabilities have
been discovered.

Background
==========

Tikiwiki is a web-based groupware and content management system (CMS),
using PHP, ADOdb and Smarty.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 www-apps/tikiwiki < 1.9.4 >= 1.9.4

Description
===========

Tikiwiki fails to properly sanitize user input before processing it,
including in SQL statements.

Impact
======

An attacker could execute arbitrary SQL statements on the underlying
database, or inject arbitrary scripts into the context of a user's
browser.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Tikiwiki users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=www-apps/tikiwiki-1.9.4"

References
==========

[ 1 ] CVE-2006-3048
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3048
[ 2 ] CVE-2006-3047
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3047

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200606-29.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart7254225.Y6lKhQ1C1R
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBEo13MzKC5hMHO6rkRAnbEAJ4njr9BXNLDnMObyMLWXSsSgdkj9QCgkIs1
js7hzuRX/55N4gxLxqWvliI=
=LSYL
-----END PGP SIGNATURE-----

--nextPart7254225.Y6lKhQ1C1R--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung