Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in PostgreSQL
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in PostgreSQL
ID: 200607-04
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 9. Juli 2006, 19:05
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2313
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2314
http://www.postgresql.org/docs/techdocs.50
Applikationen: PostgreSQL

Originalnachricht

--nextPart4035510.WEmk4Q5rRV
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200607-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PostgreSQL: SQL injection
Date: July 09, 2006
Bugs: #134168
ID: 200607-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A flaw in the multibyte character handling allows execution of
arbitrary SQL statements.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/postgresql < 8.0.8 >= 8.0.8
*>= 7.4.13

Description
===========

PostgreSQL contains a flaw in the string parsing routines that allows
certain backslash-escaped characters to be bypassed with some multibyte
character encodings. This vulnerability was discovered by Akio Ishida
and Yasuo Ohgaki.

Impact
======

An attacker could execute arbitrary SQL statements on the PostgreSQL
server. Be aware that web applications using PostgreSQL as a database
back-end might be used to exploit this vulnerability.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL users should upgrade to the latest version in the
respective branch they are using:

# emerge --sync
# emerge --ask --oneshot --verbose dev-db/postgresql

Note: While a fix exists for the 7.3 branch it doesn't currently work
on Gentoo. All 7.3.x users of PostgreSQL should consider updating their
installations to the 7.4 (or higher) branch as soon as possible!

References
==========

[ 1 ] PostgreSQL technical information
http://www.postgresql.org/docs/techdocs.50
[ 2 ] CVE-2006-2313
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2313
[ 3 ] CVE-2006-2314
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2314

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200607-04.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart4035510.WEmk4Q5rRV
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBEsTSUzKC5hMHO6rkRAuWSAJ4hst8Bnz9ShViZrpTsUQ/GpTY73wCdEXxI
A6UDO9HXBTkVTtl6Ijx0+/U=
=+BQn
-----END PGP SIGNATURE-----

--nextPart4035510.WEmk4Q5rRV--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Unterstützer werden
Neue Nachrichten
Werbung