Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in gettext-runtime
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in gettext-runtime
ID: openSUSE-SU-2020:1278-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.2
Datum: Fr, 28. August 2020, 07:05
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-18751
Applikationen: gettext

Originalnachricht

   openSUSE Security Update: Security update for gettext-runtime
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1278-1
Rating: moderate
References: #1106843 #1113719 #941629
Cross-References: CVE-2018-18751
Affected Products:
openSUSE Leap 15.2
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for gettext-runtime fixes the following issues:

- Fix boo941629-unnessary-rpath-on-standard-path.patch (bsc#941629)
- Added msgfmt-double-free.patch to fix a double free error
(CVE-2018-18751 bsc#1113719)
- Add patch msgfmt-reset-msg-length-after-remove.patch which does reset
the length of message string after a line has been removed (bsc#1106843)

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.2:

zypper in -t patch openSUSE-2020-1278=1



Package List:

- openSUSE Leap 15.2 (i586 x86_64):

gettext-runtime-0.19.8.1-lp152.6.3.1
gettext-runtime-debuginfo-0.19.8.1-lp152.6.3.1
gettext-runtime-debugsource-0.19.8.1-lp152.6.3.1
gettext-runtime-mini-0.19.8.1-lp152.6.3.1
gettext-runtime-mini-debuginfo-0.19.8.1-lp152.6.3.1
gettext-runtime-mini-debugsource-0.19.8.1-lp152.6.3.1
gettext-tools-0.19.8.1-lp152.6.3.1
gettext-tools-debuginfo-0.19.8.1-lp152.6.3.1
gettext-tools-mini-0.19.8.1-lp152.6.3.1
gettext-tools-mini-debuginfo-0.19.8.1-lp152.6.3.1

- openSUSE Leap 15.2 (noarch):

gettext-runtime-mini-tools-doc-0.19.8.1-lp152.6.3.1
gettext-runtime-tools-doc-0.19.8.1-lp152.6.3.1

- openSUSE Leap 15.2 (x86_64):

gettext-csharp-0.19.8.1-lp152.6.3.1
gettext-java-0.19.8.1-lp152.6.3.1
gettext-runtime-32bit-0.19.8.1-lp152.6.3.1
gettext-runtime-32bit-debuginfo-0.19.8.1-lp152.6.3.1


References:

https://www.suse.com/security/cve/CVE-2018-18751.html
https://bugzilla.suse.com/1106843
https://bugzilla.suse.com/1113719
https://bugzilla.suse.com/941629

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung