Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in xorg-x11-server
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in xorg-x11-server
ID: openSUSE-SU-2020:1374-1
Distribution: SUSE
Plattformen: SUSE openSUSE Leap 15.1
Datum: Di, 8. September 2020, 07:45
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14361
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14362
Applikationen: X11

Originalnachricht

   openSUSE Security Update: Security update for xorg-x11-server
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:1374-1
Rating: important
References: #1174910 #1174913
Cross-References: CVE-2020-14361 CVE-2020-14362
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for xorg-x11-server fixes the following issues:

- CVE-2020-14361: Fix XkbSelectEvents() integer underflow (bsc#1174910
ZDI-CAN-11573).
- CVE-2020-14362: Fix XRecordRegisterClients() Integer underflow
(bsc#1174913 ZDI-CAN-11574).

This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-1374=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

xorg-x11-server-1.20.3-lp151.4.6.1
xorg-x11-server-debuginfo-1.20.3-lp151.4.6.1
xorg-x11-server-debugsource-1.20.3-lp151.4.6.1
xorg-x11-server-extra-1.20.3-lp151.4.6.1
xorg-x11-server-extra-debuginfo-1.20.3-lp151.4.6.1
xorg-x11-server-sdk-1.20.3-lp151.4.6.1
xorg-x11-server-source-1.20.3-lp151.4.6.1
xorg-x11-server-wayland-1.20.3-lp151.4.6.1
xorg-x11-server-wayland-debuginfo-1.20.3-lp151.4.6.1


References:

https://www.suse.com/security/cve/CVE-2020-14361.html
https://www.suse.com/security/cve/CVE-2020-14362.html
https://bugzilla.suse.com/1174910
https://bugzilla.suse.com/1174913

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@opensuse.org
For additional commands, e-mail: opensuse-security-announce+help@opensuse.org
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung