Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in libxml2
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in libxml2
ID: SUSE-SU-2020:2612-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15-SP1, SUSE Linux Enterprise Module for Python2 15-SP1, SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Module for Python2 15-SP2
Datum: Fr, 11. September 2020, 23:42
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24977
Applikationen: libxml2

Originalnachricht


SUSE Security Update: Security update for libxml2
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:2612-1
Rating: moderate
References: #1176179
Cross-References: CVE-2020-24977
Affected Products:
SUSE Linux Enterprise Module for Python2 15-SP2
SUSE Linux Enterprise Module for Python2 15-SP1
SUSE Linux Enterprise Module for Basesystem 15-SP2
SUSE Linux Enterprise Module for Basesystem 15-SP1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for libxml2 fixes the following issues:

- CVE-2020-24977: Fixed a global-buffer-overflow in
xmlEncodeEntitiesInternal (bsc#1176179).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Python2 15-SP2:

zypper in -t patch SUSE-SLE-Module-Python2-15-SP2-2020-2612=1

- SUSE Linux Enterprise Module for Python2 15-SP1:

zypper in -t patch SUSE-SLE-Module-Python2-15-SP1-2020-2612=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2020-2612=1

- SUSE Linux Enterprise Module for Basesystem 15-SP1:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-2612=1



Package List:

- SUSE Linux Enterprise Module for Python2 15-SP2 (aarch64 ppc64le s390x
x86_64):

python-libxml2-python-debugsource-2.9.7-3.25.1
python2-libxml2-python-2.9.7-3.25.1
python2-libxml2-python-debuginfo-2.9.7-3.25.1

- SUSE Linux Enterprise Module for Python2 15-SP1 (aarch64 ppc64le s390x
x86_64):

python-libxml2-python-debugsource-2.9.7-3.25.1
python2-libxml2-python-2.9.7-3.25.1
python2-libxml2-python-debuginfo-2.9.7-3.25.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 ppc64le s390x
x86_64):

libxml2-2-2.9.7-3.25.1
libxml2-2-debuginfo-2.9.7-3.25.1
libxml2-debugsource-2.9.7-3.25.1
libxml2-devel-2.9.7-3.25.1
libxml2-tools-2.9.7-3.25.1
libxml2-tools-debuginfo-2.9.7-3.25.1
python-libxml2-python-debugsource-2.9.7-3.25.1
python3-libxml2-python-2.9.7-3.25.1
python3-libxml2-python-debuginfo-2.9.7-3.25.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (x86_64):

libxml2-2-32bit-2.9.7-3.25.1
libxml2-2-32bit-debuginfo-2.9.7-3.25.1

- SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x
x86_64):

libxml2-2-2.9.7-3.25.1
libxml2-2-debuginfo-2.9.7-3.25.1
libxml2-debugsource-2.9.7-3.25.1
libxml2-devel-2.9.7-3.25.1
libxml2-tools-2.9.7-3.25.1
libxml2-tools-debuginfo-2.9.7-3.25.1
python-libxml2-python-debugsource-2.9.7-3.25.1
python3-libxml2-python-2.9.7-3.25.1
python3-libxml2-python-debuginfo-2.9.7-3.25.1

- SUSE Linux Enterprise Module for Basesystem 15-SP1 (x86_64):

libxml2-2-32bit-2.9.7-3.25.1
libxml2-2-32bit-debuginfo-2.9.7-3.25.1


References:

https://www.suse.com/security/cve/CVE-2020-24977.html
https://bugzilla.suse.com/1176179

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung