Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in Qt GUI
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in Qt GUI
ID: 202009-04
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mo, 14. September 2020, 07:46
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2020-17507
Applikationen: Qt

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--QeXJ9APmMidMz13k7oiVXbXSvOKE2EKcc
Content-Type: multipart/mixed;
boundary="9Xlh0uKs0BE4LXYItuhdSnT8yXNRyqq3k"

--9Xlh0uKs0BE4LXYItuhdSnT8yXNRyqq3k
Content-Type: text/plain; charset=utf-8
Content-Language: en-U
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202009-04
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: Qt GUI: Buffer overflow
Date: September 13, 2020
Bugs: #736924
ID: 202009-04

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Qt GUI has a buffer overflow with unspecified impact.

Background
==========

The GUI module and platform plugins for the Qt5 framework.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-qt/qtgui < 5.14.2-r1 >= 5.14.2-r1

Description
===========

It was discovered that Qt GUI's XBM parser did not properly handle X
BitMap files.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Qt GUI users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-qt/qtgui-5.14.2-r1"

References
==========

[ 1 ] CVE-2020-17507
https://nvd.nist.gov/vuln/detail/CVE-2020-17507

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202009-04

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5


--9Xlh0uKs0BE4LXYItuhdSnT8yXNRyqq3k--

--QeXJ9APmMidMz13k7oiVXbXSvOKE2EKcc
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQGTBAEBCgB9FiEEExKRzo+LDXJgXHuURObr3Jv2BVkFAl9eq3JfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDEz
MTI5MUNFOEY4QjBENzI2MDVDN0I5NDQ0RTZFQkRDOUJGNjA1NTkACgkQRObr3Jv2
BVngIwf/dlSKzhBkRYNtx/CGEl1DE4Q3Jof1cAVkuNlXQw5vsdBNRHbPBGXYigh7
xgSWIK4YmA27hJUvGTbN8KTqBjVXo/QuSF8CCuNnqi3eDDuOb5Cv3d4cG9fbJW6T
QsvefKj9jJIO1U9u4VfAgoPGZGVfOK6dikrCX1M/C6iKKTogA0+o7uFoXILpKuO1
Mizbg7dFjcGVkpZqt9lohzX4rLgVwDJYNxUeKuHYFQXiIHQauyfWfn6O20qIoS2f
4Mn78r6VaXA+0lkbySzOWVbg4cOWlr7bbWmG7X4wxJfA7+aT5Vav2HahHgRDzYEC
irBuGZqfeCU85B0AGXlc2K0XrbsFCA==
=4E2E
-----END PGP SIGNATURE-----

--QeXJ9APmMidMz13k7oiVXbXSvOKE2EKcc--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung