Login
Newsletter
Werbung

Sicherheit: Mangelnde Prüfung von Zertifikaten in tigervnc
Aktuelle Meldungen Distributionen
Name: Mangelnde Prüfung von Zertifikaten in tigervnc
ID: SUSE-SU-2020:2881-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server for SAP 12-SP4, SUSE OpenStack Cloud 9, SUSE OpenStack Cloud Crowbar 9, SUSE Linux Enterprise Server 12-SP5, SUSE Linux Enterprise Server 12-SP4-LTSS
Datum: Fr, 9. Oktober 2020, 22:26
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-26117
Applikationen: TigerVNC

Originalnachricht


SUSE Security Update: Security update for tigervnc
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:2881-1
Rating: critical
References: #1176733
Cross-References: CVE-2020-26117
Affected Products:
SUSE OpenStack Cloud Crowbar 9
SUSE OpenStack Cloud 9
SUSE Linux Enterprise Server for SAP 12-SP4
SUSE Linux Enterprise Server 12-SP5
SUSE Linux Enterprise Server 12-SP4-LTSS
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for tigervnc fixes the following issues:

- CVE-2020-26117: Server certificates were stored as certiticate
authorities, allowing malicious owners of these certificates to
impersonate any server after a client had added an exception
(bsc#1176733)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE OpenStack Cloud Crowbar 9:

zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2020-2881=1

- SUSE OpenStack Cloud 9:

zypper in -t patch SUSE-OpenStack-Cloud-9-2020-2881=1

- SUSE Linux Enterprise Server for SAP 12-SP4:

zypper in -t patch SUSE-SLE-SAP-12-SP4-2020-2881=1

- SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2020-2881=1

- SUSE Linux Enterprise Server 12-SP4-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2020-2881=1



Package List:

- SUSE OpenStack Cloud Crowbar 9 (x86_64):

libXvnc1-1.6.0-22.17.1
libXvnc1-debuginfo-1.6.0-22.17.1
tigervnc-1.6.0-22.17.1
tigervnc-debuginfo-1.6.0-22.17.1
tigervnc-debugsource-1.6.0-22.17.1
xorg-x11-Xvnc-1.6.0-22.17.1
xorg-x11-Xvnc-debuginfo-1.6.0-22.17.1

- SUSE OpenStack Cloud 9 (x86_64):

libXvnc1-1.6.0-22.17.1
libXvnc1-debuginfo-1.6.0-22.17.1
tigervnc-1.6.0-22.17.1
tigervnc-debuginfo-1.6.0-22.17.1
tigervnc-debugsource-1.6.0-22.17.1
xorg-x11-Xvnc-1.6.0-22.17.1
xorg-x11-Xvnc-debuginfo-1.6.0-22.17.1

- SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

libXvnc1-1.6.0-22.17.1
libXvnc1-debuginfo-1.6.0-22.17.1
tigervnc-1.6.0-22.17.1
tigervnc-debuginfo-1.6.0-22.17.1
tigervnc-debugsource-1.6.0-22.17.1
xorg-x11-Xvnc-1.6.0-22.17.1
xorg-x11-Xvnc-debuginfo-1.6.0-22.17.1

- SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

libXvnc1-1.6.0-22.17.1
libXvnc1-debuginfo-1.6.0-22.17.1
tigervnc-1.6.0-22.17.1
tigervnc-debuginfo-1.6.0-22.17.1
tigervnc-debugsource-1.6.0-22.17.1
xorg-x11-Xvnc-1.6.0-22.17.1
xorg-x11-Xvnc-debuginfo-1.6.0-22.17.1

- SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

libXvnc1-1.6.0-22.17.1
libXvnc1-debuginfo-1.6.0-22.17.1
tigervnc-1.6.0-22.17.1
tigervnc-debuginfo-1.6.0-22.17.1
tigervnc-debugsource-1.6.0-22.17.1
xorg-x11-Xvnc-1.6.0-22.17.1
xorg-x11-Xvnc-debuginfo-1.6.0-22.17.1


References:

https://www.suse.com/security/cve/CVE-2020-26117.html
https://bugzilla.suse.com/1176733

_______________________________________________
sle-security-updates mailing list
sle-security-updates@lists.suse.com
http://lists.suse.com/mailman/listinfo/sle-security-updates
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung