Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in gnutls
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in gnutls
ID: SUSE-SU-2020:2988-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15-SP1, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise High Performance Computing 15-LTSS
Datum: Mi, 21. Oktober 2020, 22:58
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24659
Applikationen: GNU Transport Layer Security Library

Originalnachricht


SUSE Security Update: Security update for gnutls
______________________________________________________________________________

Announcement ID: SUSE-SU-2020:2988-1
Rating: moderate
References: #1176086 #1176181 #1176671
Cross-References: CVE-2020-24659
Affected Products:
SUSE Linux Enterprise Server for SAP 15
SUSE Linux Enterprise Server 15-LTSS
SUSE Linux Enterprise Module for Basesystem 15-SP1
SUSE Linux Enterprise High Performance Computing 15-LTSS
SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:

This update for gnutls fixes the following issues:

- Fix heap buffer overflow in handshake with no_renegotiation alert sent
(CVE-2020-24659 bsc#1176181)
- FIPS: Implement (EC)DH requirements from SP800-56Arev3 (bsc#1176086)
- FIPS: Use 2048 bit prime in DH selftest (bsc#1176086)
- FIPS: Add TLS KDF selftest (bsc#1176671)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server for SAP 15:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2020-2988=1

- SUSE Linux Enterprise Server 15-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-2020-2988=1

- SUSE Linux Enterprise Module for Basesystem 15-SP1:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP1-2020-2988=1

- SUSE Linux Enterprise High Performance Computing 15-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-2988=1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2020-2988=1



Package List:

- SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

gnutls-3.6.7-6.34.1
gnutls-debuginfo-3.6.7-6.34.1
gnutls-debugsource-3.6.7-6.34.1
libgnutls-devel-3.6.7-6.34.1
libgnutls30-3.6.7-6.34.1
libgnutls30-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-3.6.7-6.34.1
libgnutlsxx-devel-3.6.7-6.34.1
libgnutlsxx28-3.6.7-6.34.1
libgnutlsxx28-debuginfo-3.6.7-6.34.1

- SUSE Linux Enterprise Server for SAP 15 (x86_64):

libgnutls30-32bit-3.6.7-6.34.1
libgnutls30-32bit-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-32bit-3.6.7-6.34.1

- SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

gnutls-3.6.7-6.34.1
gnutls-debuginfo-3.6.7-6.34.1
gnutls-debugsource-3.6.7-6.34.1
libgnutls-devel-3.6.7-6.34.1
libgnutls30-3.6.7-6.34.1
libgnutls30-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-3.6.7-6.34.1
libgnutlsxx-devel-3.6.7-6.34.1
libgnutlsxx28-3.6.7-6.34.1
libgnutlsxx28-debuginfo-3.6.7-6.34.1

- SUSE Linux Enterprise Module for Basesystem 15-SP1 (aarch64 ppc64le s390x
x86_64):

gnutls-3.6.7-6.34.1
gnutls-debuginfo-3.6.7-6.34.1
gnutls-debugsource-3.6.7-6.34.1
libgnutls-devel-3.6.7-6.34.1
libgnutls30-3.6.7-6.34.1
libgnutls30-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-3.6.7-6.34.1
libgnutlsxx-devel-3.6.7-6.34.1
libgnutlsxx28-3.6.7-6.34.1
libgnutlsxx28-debuginfo-3.6.7-6.34.1

- SUSE Linux Enterprise Module for Basesystem 15-SP1 (x86_64):

libgnutls30-32bit-3.6.7-6.34.1
libgnutls30-32bit-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-32bit-3.6.7-6.34.1

- SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

gnutls-3.6.7-6.34.1
gnutls-debuginfo-3.6.7-6.34.1
gnutls-debugsource-3.6.7-6.34.1
libgnutls-devel-3.6.7-6.34.1
libgnutls30-3.6.7-6.34.1
libgnutls30-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-3.6.7-6.34.1
libgnutlsxx-devel-3.6.7-6.34.1
libgnutlsxx28-3.6.7-6.34.1
libgnutlsxx28-debuginfo-3.6.7-6.34.1

- SUSE Linux Enterprise High Performance Computing 15-LTSS (x86_64):

libgnutls30-32bit-3.6.7-6.34.1
libgnutls30-32bit-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-32bit-3.6.7-6.34.1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64
x86_64):

gnutls-3.6.7-6.34.1
gnutls-debuginfo-3.6.7-6.34.1
gnutls-debugsource-3.6.7-6.34.1
libgnutls-devel-3.6.7-6.34.1
libgnutls30-3.6.7-6.34.1
libgnutls30-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-3.6.7-6.34.1
libgnutlsxx-devel-3.6.7-6.34.1
libgnutlsxx28-3.6.7-6.34.1
libgnutlsxx28-debuginfo-3.6.7-6.34.1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (x86_64):

libgnutls30-32bit-3.6.7-6.34.1
libgnutls30-32bit-debuginfo-3.6.7-6.34.1
libgnutls30-hmac-32bit-3.6.7-6.34.1


References:

https://www.suse.com/security/cve/CVE-2020-24659.html
https://bugzilla.suse.com/1176086
https://bugzilla.suse.com/1176181
https://bugzilla.suse.com/1176671
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung