Login
Newsletter
Werbung

Sicherheit: Mangelnde Eingabeprüfung in LibVNCServer
Aktuelle Meldungen Distributionen
Name: Mangelnde Eingabeprüfung in LibVNCServer
ID: 200608-05
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Fr, 4. August 2006, 07:17
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2450
Applikationen: LibVNCServer

Originalnachricht

--nextPart1315311.etzfojQH1O
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200608-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: LibVNCServer: Authentication bypass
Date: August 04, 2006
Bugs: #136916
ID: 200608-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

VNC servers created with LibVNCServer accept insecure protocol types,
even when the server does not offer it, resulting in unauthorized
access to the server.

Background
==========

LibVNCServer is a GPL'ed library for creating VNC servers.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-libs/libvncserver < 0.8.2 >= 0.8.2

Description
===========

LibVNCServer fails to properly validate protocol types effectively
letting users decide what protocol to use, such as "Type 1 - None".
LibVNCServer will accept this security type, even if it is not offered
by the server.

Impact
======

An attacker could use this vulnerability to gain unauthorized access
with the privileges of the user running the VNC server.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All LibVNCServer users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=net-libs/libvncserver-0.8.2"

References
==========

[ 1 ] CVE-2006-2450
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-2450

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200608-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart1315311.etzfojQH1O
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBE0tHOzKC5hMHO6rkRAp9+AJsGtAC0TLecYO8s1QqkNRr1qt5ZaQCeN+Zc
/UTOq4YMEY0jMS/MWWWgy7c=
=g7y/
-----END PGP SIGNATURE-----

--nextPart1315311.etzfojQH1O--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung