Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in MySQL
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in MySQL
ID: 200608-09
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: So, 6. August 2006, 21:29
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3469
Applikationen: MySQL

Originalnachricht

--nextPart3628103.1S3lkypmy0
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200608-09
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: MySQL: Denial of Service
Date: August 06, 2006
Bugs: #142429
ID: 200608-09

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

An authenticated user can crash MySQL through invalid parameters to the
date_format function.

Background
==========

MySQL is a popular multi-threaded, multi-user SQL server.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/mysql < 4.1.21 >= 4.1.21

Description
===========

Jean-David Maillefer discovered a format string vulnerability in
time.cc where MySQL fails to properly handle specially formatted user
input to the date_format function.

Impact
======

By specifying a format string as the first parameter to the date_format
function, an authenticated attacker could cause MySQL to crash,
resulting in a Denial of Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MySQL users should upgrade to the latest version:

# emerge --sync
# emerge --ask --verbose --oneshot ">=dev-db/mysql-4.1.21"

References
==========

[ 1 ] CVE-2006-3469
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-3469

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200608-09.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2006 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart3628103.1S3lkypmy0
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBE1kFHzKC5hMHO6rkRAhgBAJ498kKMo6tCtcg+lWvoBDfnLrSzPwCfWC7K
xZFa65uE1jSIenF7DR66CrU=
=Zaci
-----END PGP SIGNATURE-----

--nextPart3628103.1S3lkypmy0--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung