Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in go1.14
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in go1.14
ID: SUSE-SU-2021:0222-1
Distribution: SUSE
Plattformen: SUSE Enterprise Storage 6, SUSE CaaS Platform 4.0, SUSE Linux Enterprise Module for Development Tools 15-SP2, SUSE Linux Enterprise Module for Development Tools 15-SP3, SUSE Linux Enterprise Server for SAP 15-SP1, SUSE Manager Server 4.0, SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS, SUSE Linux Enterprise Server 15-SP1-LTSS, SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS, SUSE Manager Proxy 4.0, SUSE Manager Retail Branch Server 4.0, SUSE Linux Enterprise Server 15-SP1-BCL
Datum: Di, 26. Januar 2021, 21:15
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3115
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3114
Applikationen: Go

Originalnachricht


SUSE Security Update: Security update for go1.14
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:0222-1
Rating: moderate
References: #1164903 #1181145 #1181146
Cross-References: CVE-2021-3114 CVE-2021-3115
Affected Products:
SUSE Manager Server 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Proxy 4.0
SUSE Linux Enterprise Server for SAP 15-SP1
SUSE Linux Enterprise Server 15-SP1-LTSS
SUSE Linux Enterprise Server 15-SP1-BCL
SUSE Linux Enterprise Module for Development Tools 15-SP3
SUSE Linux Enterprise Module for Development Tools 15-SP2
SUSE Linux Enterprise High Performance Computing
15-SP1-LTSS
SUSE Linux Enterprise High Performance Computing
15-SP1-ESPOS
SUSE Enterprise Storage 6
SUSE CaaS Platform 4.0
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for go1.14 fixes the following issues:

Go was updated to version 1.14.14 (bsc#1164903).

Security issues fixed:

- CVE-2021-3114: Fixed incorrect operations on the P-224 curve in
crypto/elliptic (bsc#1181145).
- CVE-2021-3115: Fixed a potential arbitrary code execution in the build
process (bsc#1181146).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Manager Server 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-222=1

- SUSE Manager Retail Branch Server 4.0:

zypper in -t patch
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-222=1

- SUSE Manager Proxy 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-222=1

- SUSE Linux Enterprise Server for SAP 15-SP1:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-222=1

- SUSE Linux Enterprise Server 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-222=1

- SUSE Linux Enterprise Server 15-SP1-BCL:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-222=1

- SUSE Linux Enterprise Module for Development Tools 15-SP3:

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP3-2021-222=1

- SUSE Linux Enterprise Module for Development Tools 15-SP2:

zypper in -t patch SUSE-SLE-Module-Development-Tools-15-SP2-2021-222=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-222=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-222=1

- SUSE Enterprise Storage 6:

zypper in -t patch SUSE-Storage-6-2021-222=1

- SUSE CaaS Platform 4.0:

To install this update, use the SUSE CaaS Platform 'skuba' tool.
It
will inform you if it detects new updates and let you then trigger
updating of the complete cluster in a controlled way.



Package List:

- SUSE Manager Server 4.0 (ppc64le s390x x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Manager Retail Branch Server 4.0 (x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Manager Proxy 4.0 (x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Linux Enterprise Module for Development Tools 15-SP3 (aarch64 ppc64le
s390x x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Linux Enterprise Module for Development Tools 15-SP2 (aarch64 ppc64le
s390x x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64
x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64
x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE Enterprise Storage 6 (aarch64 x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1

- SUSE CaaS Platform 4.0 (x86_64):

go1.14-1.14.14-1.32.1
go1.14-doc-1.14.14-1.32.1


References:

https://www.suse.com/security/cve/CVE-2021-3114.html
https://www.suse.com/security/cve/CVE-2021-3115.html
https://bugzilla.suse.com/1164903
https://bugzilla.suse.com/1181145
https://bugzilla.suse.com/1181146
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung