Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in sudo
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in sudo
ID: 202101-33
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mi, 27. Januar 2021, 07:16
Referenzen: https://www.sudo.ws/alerts/unescape_overflow.html
https://nvd.nist.gov/vuln/detail/CVE-2021-3156
https://nvd.nist.gov/vuln/detail/CVE-2021-23240
https://www.sudo.ws/alerts/sudoedit_selinux.html
https://nvd.nist.gov/vuln/detail/CVE-2021-23239
Applikationen: sudo

Originalnachricht


--Apple-Mail=_70104732-F08C-4789-A4A2-BD8BC959807C
Content-Type: multipart/alternative;
boundary="Apple-Mail=_A7D00F96-9B41-4679-98BC-7B171C9C16F2"


--Apple-Mail=_A7D00F96-9B41-4679-98BC-7B171C9C16F2
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
charset=us-ascii

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202101-33
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: sudo: Multiple vulnerabilities
Date: January 26, 2021
Bugs: #764986, #767364
ID: 202101-33

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in sudo, the worst of which
could result in privilege escalation.

Background
==========

sudo (su "do") allows a system administrator to delegate authority to
give certain users (or groups of users) the ability to run some (or
all) commands as root or another user while providing an audit trail of
the commands and their arguments.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-admin/sudo < 1.9.5_p2 >= 1.9.5_p2

Description
===========

Multiple vulnerabilities have been discovered in sudo. Please review
the CVE identifiers referenced below for details.

Impact
======

Local users are able to gain unauthorized privileges on the system or
determine the existence of files.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All sudo users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-admin/sudo-1.9.5_p2"

References
==========

[ 1 ] CVE-2021-23239
https://nvd.nist.gov/vuln/detail/CVE-2021-23239
[ 2 ] CVE-2021-23240
https://nvd.nist.gov/vuln/detail/CVE-2021-23240
[ 3 ] CVE-2021-3156
https://nvd.nist.gov/vuln/detail/CVE-2021-3156
[ 4 ] Upstream advisory (CVE-2020-23240)
https://www.sudo.ws/alerts/sudoedit_selinux.html
[ 5 ] Upstream advisory (CVE-2021-3156)
https://www.sudo.ws/alerts/unescape_overflow.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202101-33

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5


--Apple-Mail=_A7D00F96-9B41-4679-98BC-7B171C9C16F2
Content-Transfer-Encoding: 7bit
Content-Type: text/html;
charset=us-ascii

<html><head><meta http-equiv="Content-Type"
content="text/html; charset=us-ascii"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><pre style="word-wrap: break-word; white-space: pre-wrap;" class="">- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202101-33
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
<a href="https://security.gentoo.org/" class="">https://security.gentoo.org/</a>
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: sudo: Multiple vulnerabilities
Date: January 26, 2021
Bugs: #764986, #767364
ID: 202101-33

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in sudo, the worst of which
could result in privilege escalation.

Background
==========

sudo (su "do") allows a system administrator to delegate authority to
give certain users (or groups of users) the ability to run some (or
all) commands as root or another user while providing an audit trail of
the commands and their arguments.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-admin/sudo &lt; 1.9.5_p2 &gt;=
1.9.5_p2

Description
===========

Multiple vulnerabilities have been discovered in sudo. Please review
the CVE identifiers referenced below for details.

Impact
======

Local users are able to gain unauthorized privileges on the system or
determine the existence of files.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All sudo users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose "&gt;=app-admin/sudo-1.9.5_p2"

References
==========

[ 1 ] CVE-2021-23239
<a href="https://nvd.nist.gov/vuln/detail/CVE-2021-23239" class="">https://nvd.nist.gov/vuln/detail/CVE-2021-23239</a>
[ 2 ] CVE-2021-23240
<a href="https://nvd.nist.gov/vuln/detail/CVE-2021-23240" class="">https://nvd.nist.gov/vuln/detail/CVE-2021-23240</a>
[ 3 ] CVE-2021-3156
<a href="https://nvd.nist.gov/vuln/detail/CVE-2021-3156" class="">https://nvd.nist.gov/vuln/detail/CVE-2021-3156</a>
[ 4 ] Upstream advisory (CVE-2020-23240)
<a href="https://www.sudo.ws/alerts/sudoedit_selinux.html" class="">https://www.sudo.ws/alerts/sudoedit_selinux.html</a>
[ 5 ] Upstream advisory (CVE-2021-3156)
<a href="https://www.sudo.ws/alerts/unescape_overflow.html" class="">https://www.sudo.ws/alerts/unescape_overflow.html</a>

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

<a href="https://security.gentoo.org/glsa/202101-33" class="">https://security.gentoo.org/glsa/202101-33</a>

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
<a href="mailto:security@gentoo.org"
class="">security@gentoo.org</a> or alternatively, you may file a bug at
<a href="https://bugs.gentoo.org" class="">https://bugs.gentoo.org</a>.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

<a href="https://creativecommons.org/licenses/by-sa/2.5" class="">https://creativecommons.org/licenses/by-sa/2.5</a></pre><div class=""><br class=""></div></body></html>
--Apple-Mail=_A7D00F96-9B41-4679-98BC-7B171C9C16F2--

--Apple-Mail=_70104732-F08C-4789-A4A2-BD8BC959807C
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment;
filename=signature.asc
Content-Type: application/pgp-signature;
name=signature.asc
Content-Description: Message signed with OpenPGP

-----BEGIN PGP SIGNATURE-----

iNUEARYKAH0WIQSONjK3ErBA5VvN3hCxfj6E5hA8mwUCYBColF8UgAAAAAAuAChp
c3N1ZXItZnByQG5vdGF0aW9ucy5vcGVucGdwLmZpZnRoaG9yc2VtYW4ubmV0OEUz
NjMyQjcxMkIwNDBFNTVCQ0RERTEwQjE3RTNFODRFNjEwM0M5QgAKCRCxfj6E5hA8
mxKgAQCZg8aj9JEIJvS4Gn4samBIsBJ8ZpIdui42bdK/hx8xPwD/Va1ABNm/fTYs
dh0o7fj8jYmlBzQbtQF2QUBAPi2G+AA=
=rTUf
-----END PGP SIGNATURE-----

--Apple-Mail=_70104732-F08C-4789-A4A2-BD8BC959807C--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung