Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in sudo
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in sudo
ID: SUSE-SU-2021:0232-1
Distribution: SUSE
Plattformen: SUSE OpenStack Cloud 7, SUSE Linux Enterprise Server for SAP 12-SP2, SUSE Linux Enterprise Server 12-SP2-LTSS, SUSE Linux Enterprise Server 12-SP2-BCL
Datum: Mi, 27. Januar 2021, 15:33
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3156
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-23239
Applikationen: sudo

Originalnachricht


SUSE Security Update: Security update for sudo
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:0232-1
Rating: important
References: #1180684 #1181090
Cross-References: CVE-2021-23239 CVE-2021-3156
Affected Products:
SUSE OpenStack Cloud 7
SUSE Linux Enterprise Server for SAP 12-SP2
SUSE Linux Enterprise Server 12-SP2-LTSS
SUSE Linux Enterprise Server 12-SP2-BCL
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for sudo fixes the following issues:

- A Heap-based buffer overflow in sudo could be exploited to allow a user
to gain root privileges [bsc#1181090,CVE-2021-3156]
- It was possible for a user to test for the existence of a directory due
to a Race Condition in `sudoedit` [bsc#1180684,CVE-2021-23239]


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE OpenStack Cloud 7:

zypper in -t patch SUSE-OpenStack-Cloud-7-2021-232=1

- SUSE Linux Enterprise Server for SAP 12-SP2:

zypper in -t patch SUSE-SLE-SAP-12-SP2-2021-232=1

- SUSE Linux Enterprise Server 12-SP2-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2021-232=1

- SUSE Linux Enterprise Server 12-SP2-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2021-232=1



Package List:

- SUSE OpenStack Cloud 7 (s390x x86_64):

sudo-1.8.10p3-10.29.1
sudo-debuginfo-1.8.10p3-10.29.1
sudo-debugsource-1.8.10p3-10.29.1

- SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):

sudo-1.8.10p3-10.29.1
sudo-debuginfo-1.8.10p3-10.29.1
sudo-debugsource-1.8.10p3-10.29.1

- SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le s390x x86_64):

sudo-1.8.10p3-10.29.1
sudo-debuginfo-1.8.10p3-10.29.1
sudo-debugsource-1.8.10p3-10.29.1

- SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

sudo-1.8.10p3-10.29.1
sudo-debuginfo-1.8.10p3-10.29.1
sudo-debugsource-1.8.10p3-10.29.1


References:

https://www.suse.com/security/cve/CVE-2021-23239.html
https://www.suse.com/security/cve/CVE-2021-3156.html
https://bugzilla.suse.com/1180684
https://bugzilla.suse.com/1181090
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung