Login
Newsletter
Werbung

Sicherheit: Denial of Service in openvswitch
Aktuelle Meldungen Distributionen
Name: Denial of Service in openvswitch
ID: SUSE-SU-2021:0298-1
Distribution: SUSE
Plattformen: SUSE OpenStack Cloud 7, SUSE Linux Enterprise Server for SAP 12-SP2, SUSE Linux Enterprise Server 12-SP2-LTSS, SUSE Linux Enterprise Server 12-SP2-BCL
Datum: Do, 4. Februar 2021, 07:37
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-27827
Applikationen: Open vSwitch

Originalnachricht


SUSE Security Update: Security update for openvswitch
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:0298-1
Rating: important
References: #1117483 #1181345
Cross-References: CVE-2020-27827
Affected Products:
SUSE OpenStack Cloud 7
SUSE Linux Enterprise Server for SAP 12-SP2
SUSE Linux Enterprise Server 12-SP2-LTSS
SUSE Linux Enterprise Server 12-SP2-BCL
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for openvswitch fixes the following issues:

- openvswitch was updated to 2.5.11
- CVE-2020-27827: Fixed a memory leak when parsing lldp packets
(bsc#1181345)
- datapath: Clear the L4 portion of the key for "later" fragments
- datapath: Properly set L4 keys on "later" IP fragments
- ofproto-dpif: Fix using uninitialised memory in user_action_cookie.
- stream-ssl: Fix crash on NULL private key and valid certificate.
- datapath: fix flow actions reallocation


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE OpenStack Cloud 7:

zypper in -t patch SUSE-OpenStack-Cloud-7-2021-298=1

- SUSE Linux Enterprise Server for SAP 12-SP2:

zypper in -t patch SUSE-SLE-SAP-12-SP2-2021-298=1

- SUSE Linux Enterprise Server 12-SP2-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-2021-298=1

- SUSE Linux Enterprise Server 12-SP2-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2021-298=1



Package List:

- SUSE OpenStack Cloud 7 (s390x x86_64):

openvswitch-2.5.11-25.26.1
openvswitch-debuginfo-2.5.11-25.26.1
openvswitch-debugsource-2.5.11-25.26.1
openvswitch-switch-2.5.11-25.26.1
openvswitch-switch-debuginfo-2.5.11-25.26.1

- SUSE OpenStack Cloud 7 (x86_64):

openvswitch-dpdk-2.5.11-25.26.1
openvswitch-dpdk-debuginfo-2.5.11-25.26.1
openvswitch-dpdk-debugsource-2.5.11-25.26.1
openvswitch-dpdk-switch-2.5.11-25.26.1
openvswitch-dpdk-switch-debuginfo-2.5.11-25.26.1

- SUSE Linux Enterprise Server for SAP 12-SP2 (ppc64le x86_64):

openvswitch-2.5.11-25.26.1
openvswitch-debuginfo-2.5.11-25.26.1
openvswitch-debugsource-2.5.11-25.26.1
openvswitch-switch-2.5.11-25.26.1
openvswitch-switch-debuginfo-2.5.11-25.26.1

- SUSE Linux Enterprise Server for SAP 12-SP2 (x86_64):

openvswitch-dpdk-2.5.11-25.26.1
openvswitch-dpdk-debuginfo-2.5.11-25.26.1
openvswitch-dpdk-debugsource-2.5.11-25.26.1
openvswitch-dpdk-switch-2.5.11-25.26.1
openvswitch-dpdk-switch-debuginfo-2.5.11-25.26.1

- SUSE Linux Enterprise Server 12-SP2-LTSS (ppc64le s390x x86_64):

openvswitch-2.5.11-25.26.1
openvswitch-debuginfo-2.5.11-25.26.1
openvswitch-debugsource-2.5.11-25.26.1
openvswitch-switch-2.5.11-25.26.1
openvswitch-switch-debuginfo-2.5.11-25.26.1

- SUSE Linux Enterprise Server 12-SP2-LTSS (x86_64):

openvswitch-dpdk-2.5.11-25.26.1
openvswitch-dpdk-debuginfo-2.5.11-25.26.1
openvswitch-dpdk-debugsource-2.5.11-25.26.1
openvswitch-dpdk-switch-2.5.11-25.26.1
openvswitch-dpdk-switch-debuginfo-2.5.11-25.26.1

- SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

openvswitch-2.5.11-25.26.1
openvswitch-debuginfo-2.5.11-25.26.1
openvswitch-debugsource-2.5.11-25.26.1
openvswitch-dpdk-2.5.11-25.26.1
openvswitch-dpdk-debuginfo-2.5.11-25.26.1
openvswitch-dpdk-debugsource-2.5.11-25.26.1
openvswitch-dpdk-switch-2.5.11-25.26.1
openvswitch-dpdk-switch-debuginfo-2.5.11-25.26.1
openvswitch-switch-2.5.11-25.26.1
openvswitch-switch-debuginfo-2.5.11-25.26.1


References:

https://www.suse.com/security/cve/CVE-2020-27827.html
https://bugzilla.suse.com/1117483
https://bugzilla.suse.com/1181345
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung