Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in glibc
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in glibc
ID: SUSE-SU-2021:0608-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12-SP5, SUSE Linux Enterprise Software Development Kit 12-SP5
Datum: Fr, 26. Februar 2021, 00:26
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3326
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-25013
Applikationen: GNU C library

Originalnachricht


SUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:0608-1
Rating: moderate
References: #1180038 #1181365 #1181505 #1182117
Cross-References: CVE-2019-25013 CVE-2021-3326
CVSS scores:
CVE-2019-25013 (NVD) : 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2019-25013 (SUSE): 5.9
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2021-3326 (NVD) : 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2021-3326 (SUSE): 6.2
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP5
SUSE Linux Enterprise Server 12-SP5
______________________________________________________________________________

An update that solves two vulnerabilities and has two fixes
is now available.

Description:

This update for glibc fixes the following issues:

- Fix buffer overrun in EUC-KR conversion module (CVE-2019-25013,
bsc#1182117, BZ #24973)
- gconv: Fix assertion failure in ISO-2022-JP-3 module (CVE-2021-3326,
bsc#1181505, BZ #27256)
- Fix parsing of /sys/devices/system/cpu/online (bsc#1180038, BZ #25859)
- powerpc: Add support for POWER10 (bsc#1181365)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP5:

zypper in -t patch SUSE-SLE-SDK-12-SP5-2021-608=1

- SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2021-608=1



Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le
s390x x86_64):

glibc-debuginfo-2.22-114.5.1
glibc-debugsource-2.22-114.5.1
glibc-devel-static-2.22-114.5.1

- SUSE Linux Enterprise Software Development Kit 12-SP5 (noarch):

glibc-info-2.22-114.5.1

- SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

glibc-2.22-114.5.1
glibc-debuginfo-2.22-114.5.1
glibc-debugsource-2.22-114.5.1
glibc-devel-2.22-114.5.1
glibc-devel-debuginfo-2.22-114.5.1
glibc-locale-2.22-114.5.1
glibc-locale-debuginfo-2.22-114.5.1
glibc-profile-2.22-114.5.1
nscd-2.22-114.5.1
nscd-debuginfo-2.22-114.5.1

- SUSE Linux Enterprise Server 12-SP5 (s390x x86_64):

glibc-32bit-2.22-114.5.1
glibc-debuginfo-32bit-2.22-114.5.1
glibc-devel-32bit-2.22-114.5.1
glibc-devel-debuginfo-32bit-2.22-114.5.1
glibc-locale-32bit-2.22-114.5.1
glibc-locale-debuginfo-32bit-2.22-114.5.1
glibc-profile-32bit-2.22-114.5.1

- SUSE Linux Enterprise Server 12-SP5 (noarch):

glibc-html-2.22-114.5.1
glibc-i18ndata-2.22-114.5.1
glibc-info-2.22-114.5.1


References:

https://www.suse.com/security/cve/CVE-2019-25013.html
https://www.suse.com/security/cve/CVE-2021-3326.html
https://bugzilla.suse.com/1180038
https://bugzilla.suse.com/1181365
https://bugzilla.suse.com/1181505
https://bugzilla.suse.com/1182117
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung