Login
Newsletter
Werbung

Sicherheit: Denial of Service in python-Jinja2
Aktuelle Meldungen Distributionen
Name: Denial of Service in python-Jinja2
ID: SUSE-SU-2021:0654-1
Distribution: SUSE
Plattformen: SUSE Enterprise Storage 6, SUSE CaaS Platform 4.0, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Module for Python2 15-SP2, SUSE Linux Enterprise Module for Basesystem 15-SP3, SUSE Linux Enterprise Module for Python2 15-SP3, SUSE Linux Enterprise Server for SAP 15-SP1, SUSE Manager Server 4.0, SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS, SUSE Linux Enterprise Server 15-SP1-LTSS, SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS, SUSE Manager Proxy 4.0, SUSE Manager Retail Branch Server 4.0, SUSE Linux Enterprise Server 15-SP1-BCL
Datum: So, 28. Februar 2021, 08:42
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-28493
Applikationen: Jinja2

Originalnachricht


SUSE Security Update: Security update for python-Jinja2
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:0654-1
Rating: important
References: #1181944 #1182244
Cross-References: CVE-2020-28493
CVSS scores:
CVE-2020-28493 (NVD) : 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2020-28493 (SUSE): 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
SUSE Manager Server 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Proxy 4.0
SUSE Linux Enterprise Server for SAP 15-SP1
SUSE Linux Enterprise Server for SAP 15
SUSE Linux Enterprise Server 15-SP1-LTSS
SUSE Linux Enterprise Server 15-SP1-BCL
SUSE Linux Enterprise Server 15-LTSS
SUSE Linux Enterprise Module for Python2 15-SP3
SUSE Linux Enterprise Module for Python2 15-SP2
SUSE Linux Enterprise Module for Basesystem 15-SP3
SUSE Linux Enterprise Module for Basesystem 15-SP2
SUSE Linux Enterprise High Performance Computing
15-SP1-LTSS
SUSE Linux Enterprise High Performance Computing
15-SP1-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Enterprise Storage 6
SUSE CaaS Platform 4.0
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

This update for python-Jinja2 fixes the following issues:

- CVE-2020-28493: Fixed a ReDOS vulnerability where urlize could have been
called with untrusted user data (bsc#1181944).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Manager Server 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-654=1

- SUSE Manager Retail Branch Server 4.0:

zypper in -t patch
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-654=1

- SUSE Manager Proxy 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-654=1

- SUSE Linux Enterprise Server for SAP 15-SP1:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-654=1

- SUSE Linux Enterprise Server for SAP 15:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2021-654=1

- SUSE Linux Enterprise Server 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-654=1

- SUSE Linux Enterprise Server 15-SP1-BCL:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-654=1

- SUSE Linux Enterprise Server 15-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-2021-654=1

- SUSE Linux Enterprise Module for Python2 15-SP3:

zypper in -t patch SUSE-SLE-Module-Python2-15-SP3-2021-654=1

- SUSE Linux Enterprise Module for Python2 15-SP2:

zypper in -t patch SUSE-SLE-Module-Python2-15-SP2-2021-654=1

- SUSE Linux Enterprise Module for Basesystem 15-SP3:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2021-654=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-654=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-654=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-654=1

- SUSE Linux Enterprise High Performance Computing 15-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2021-654=1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2021-654=1

- SUSE Enterprise Storage 6:

zypper in -t patch SUSE-Storage-6-2021-654=1

- SUSE CaaS Platform 4.0:

To install this update, use the SUSE CaaS Platform 'skuba' tool.
It
will inform you if it detects new updates and let you then trigger
updating of the complete cluster in a controlled way.



Package List:

- SUSE Manager Server 4.0 (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Manager Retail Branch Server 4.0 (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Manager Proxy 4.0 (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Server for SAP 15-SP1 (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Server for SAP 15 (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Server 15-SP1-LTSS (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Server 15-SP1-BCL (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Server 15-LTSS (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Module for Python2 15-SP3 (noarch):

python2-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Module for Python2 15-SP2 (noarch):

python2-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Module for Basesystem 15-SP3 (noarch):

python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (noarch):

python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise High Performance Computing 15-LTSS (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE Enterprise Storage 6 (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2

- SUSE CaaS Platform 4.0 (noarch):

python2-Jinja2-2.10.1-3.10.2
python3-Jinja2-2.10.1-3.10.2


References:

https://www.suse.com/security/cve/CVE-2020-28493.html
https://bugzilla.suse.com/1181944
https://bugzilla.suse.com/1182244
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung