Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in sudo
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in sudo
ID: SUSE-SU-2021:1275-1
Distribution: SUSE
Plattformen: SUSE Enterprise Storage 6, SUSE CaaS Platform 4.0, SUSE Linux Enterprise Server 15-LTSS, SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise Server for SAP 15, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Server for SAP 15-SP1, SUSE Manager Server 4.0, SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS, SUSE Linux Enterprise Server 15-SP1-LTSS, SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS, SUSE Manager Proxy 4.0, SUSE Manager Retail Branch Server 4.0, SUSE Linux Enterprise Server 15-SP1-BCL, SUSE MicroOS 5.0
Datum: Di, 20. April 2021, 22:58
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3156
Applikationen: sudo

Originalnachricht


SUSE Security Update: Security update for sudo
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:1275-1
Rating: important
References: #1183936
Cross-References: CVE-2021-3156
CVSS scores:
CVE-2021-3156 (NVD) : 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE-2021-3156 (SUSE): 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
SUSE MicroOS 5.0
SUSE Manager Server 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Proxy 4.0
SUSE Linux Enterprise Server for SAP 15-SP1
SUSE Linux Enterprise Server for SAP 15
SUSE Linux Enterprise Server 15-SP1-LTSS
SUSE Linux Enterprise Server 15-SP1-BCL
SUSE Linux Enterprise Server 15-LTSS
SUSE Linux Enterprise Module for Basesystem 15-SP2
SUSE Linux Enterprise High Performance Computing
15-SP1-LTSS
SUSE Linux Enterprise High Performance Computing
15-SP1-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
SUSE Linux Enterprise High Performance Computing 15-ESPOS
SUSE Enterprise Storage 6
SUSE CaaS Platform 4.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for sudo fixes the following issues:

- L3: Tenable Scan reports sudo is vulnerable to CVE-2021-3156
(bsc#1183936)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE MicroOS 5.0:

zypper in -t patch SUSE-SUSE-MicroOS-5.0-2021-1275=1

- SUSE Manager Server 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-1275=1

- SUSE Manager Retail Branch Server 4.0:

zypper in -t patch
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-1275=1

- SUSE Manager Proxy 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-1275=1

- SUSE Linux Enterprise Server for SAP 15-SP1:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-1275=1

- SUSE Linux Enterprise Server for SAP 15:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-2021-1275=1

- SUSE Linux Enterprise Server 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-1275=1

- SUSE Linux Enterprise Server 15-SP1-BCL:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-1275=1

- SUSE Linux Enterprise Server 15-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-2021-1275=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-1275=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1275=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1275=1

- SUSE Linux Enterprise High Performance Computing 15-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2021-1275=1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2021-1275=1

- SUSE Enterprise Storage 6:

zypper in -t patch SUSE-Storage-6-2021-1275=1

- SUSE CaaS Platform 4.0:

To install this update, use the SUSE CaaS Platform 'skuba' tool.
It
will inform you if it detects new updates and let you then trigger
updating of the complete cluster in a controlled way.



Package List:

- SUSE MicroOS 5.0 (aarch64 x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1

- SUSE Manager Server 4.0 (ppc64le s390x x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Manager Retail Branch Server 4.0 (x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Manager Proxy 4.0 (x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise Server for SAP 15 (ppc64le x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise Server 15-SP1-LTSS (aarch64 ppc64le s390x x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise Server 15-LTSS (aarch64 s390x):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 ppc64le s390x
x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64
x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64
x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64
x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE Enterprise Storage 6 (aarch64 x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1

- SUSE CaaS Platform 4.0 (x86_64):

sudo-1.8.22-4.18.1
sudo-debuginfo-1.8.22-4.18.1
sudo-debugsource-1.8.22-4.18.1
sudo-devel-1.8.22-4.18.1


References:

https://www.suse.com/security/cve/CVE-2021-3156.html
https://bugzilla.suse.com/1183936
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung