Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in samba
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in samba
ID: SUSE-SU-2021:1444-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise High Availability 15-SP2, SUSE Linux Enterprise Module for Python2 15-SP2
Datum: Do, 29. April 2021, 22:34
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-20277
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-20254
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-27840
Applikationen: Samba

Originalnachricht


SUSE Security Update: Security update for samba
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:1444-1
Rating: important
References: #1178469 #1179156 #1183572 #1183574 #1184310
#1184677
Cross-References: CVE-2020-27840 CVE-2021-20254 CVE-2021-20277

CVSS scores:
CVE-2020-27840 (SUSE): 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2021-20254 (SUSE): 7.1
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L
CVE-2021-20277 (SUSE): 7.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H

Affected Products:
SUSE Linux Enterprise Module for Python2 15-SP2
SUSE Linux Enterprise Module for Basesystem 15-SP2
SUSE Linux Enterprise High Availability 15-SP2
______________________________________________________________________________

An update that solves three vulnerabilities and has three
fixes is now available.

Description:

This update for samba fixes the following issues:

- CVE-2021-20277: Fixed an out of bounds read in ldb_handler_fold
(bsc#1183574).
- CVE-2021-20254: Fixed a buffer overrun in sids_to_unixids()
(bsc#1184677).
- CVE-2020-27840: Fixed an unauthenticated remote heap corruption via bad
DNs (bsc#1183572).
- Avoid free'ing our own pointer in memcache when memcache_trim attempts
to reduce cache size (bsc#1179156).
- s3-libads: use dns name to open a ldap session (bsc#1184310).
- Adjust smbcacls '--propagate-inheritance' feature to align with
upstream
(bsc#1178469).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Python2 15-SP2:

zypper in -t patch SUSE-SLE-Module-Python2-15-SP2-2021-1444=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-1444=1

- SUSE Linux Enterprise High Availability 15-SP2:

zypper in -t patch SUSE-SLE-Product-HA-15-SP2-2021-1444=1



Package List:

- SUSE Linux Enterprise Module for Python2 15-SP2 (aarch64 ppc64le s390x
x86_64):

samba-ad-dc-4.11.14+git.247.8c858f7ee14-4.19.1
samba-ad-dc-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-debugsource-4.11.14+git.247.8c858f7ee14-4.19.1
samba-dsdb-modules-4.11.14+git.247.8c858f7ee14-4.19.1
samba-dsdb-modules-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 ppc64le s390x
x86_64):

libdcerpc-binding0-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc-binding0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc-samr-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc-samr0-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc-samr0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc0-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-krb5pac-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-krb5pac0-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-krb5pac0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-nbt-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-nbt0-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-nbt0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-standard-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-standard0-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-standard0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr0-4.11.14+git.247.8c858f7ee14-4.19.1
libndr0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libnetapi-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libnetapi0-4.11.14+git.247.8c858f7ee14-4.19.1
libnetapi0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-credentials-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-credentials0-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-credentials0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-errors-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-errors0-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-errors0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-hostconfig-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-hostconfig0-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-hostconfig0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-passdb-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-passdb0-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-passdb0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-policy-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-policy-python3-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-policy0-python3-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-policy0-python3-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-util-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-util0-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-util0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamdb-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsamdb0-4.11.14+git.247.8c858f7ee14-4.19.1
libsamdb0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbclient-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbclient0-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbclient0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbconf-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbconf0-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbconf0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbldap-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbldap2-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbldap2-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libtevent-util-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libtevent-util0-4.11.14+git.247.8c858f7ee14-4.19.1
libtevent-util0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libwbclient-devel-4.11.14+git.247.8c858f7ee14-4.19.1
libwbclient0-4.11.14+git.247.8c858f7ee14-4.19.1
libwbclient0-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-4.11.14+git.247.8c858f7ee14-4.19.1
samba-client-4.11.14+git.247.8c858f7ee14-4.19.1
samba-client-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-core-devel-4.11.14+git.247.8c858f7ee14-4.19.1
samba-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-debugsource-4.11.14+git.247.8c858f7ee14-4.19.1
samba-dsdb-modules-4.11.14+git.247.8c858f7ee14-4.19.1
samba-dsdb-modules-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-libs-4.11.14+git.247.8c858f7ee14-4.19.1
samba-libs-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-libs-python3-4.11.14+git.247.8c858f7ee14-4.19.1
samba-libs-python3-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-python3-4.11.14+git.247.8c858f7ee14-4.19.1
samba-python3-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-winbind-4.11.14+git.247.8c858f7ee14-4.19.1
samba-winbind-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 x86_64):

samba-ceph-4.11.14+git.247.8c858f7ee14-4.19.1
samba-ceph-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (x86_64):

libdcerpc-binding0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc-binding0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libdcerpc0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-krb5pac0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-krb5pac0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-nbt0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-nbt0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-standard0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libndr-standard0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libndr0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libndr0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libnetapi0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libnetapi0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-credentials0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-credentials0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-errors0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-errors0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-hostconfig0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-hostconfig0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-passdb0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-passdb0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-util0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsamba-util0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsamdb0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsamdb0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbconf0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbconf0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbldap2-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libsmbldap2-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libtevent-util0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libtevent-util0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
libwbclient0-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
libwbclient0-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-libs-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
samba-libs-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-winbind-32bit-4.11.14+git.247.8c858f7ee14-4.19.1
samba-winbind-32bit-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1

- SUSE Linux Enterprise High Availability 15-SP2 (aarch64 ppc64le s390x
x86_64):

ctdb-4.11.14+git.247.8c858f7ee14-4.19.1
ctdb-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-debuginfo-4.11.14+git.247.8c858f7ee14-4.19.1
samba-debugsource-4.11.14+git.247.8c858f7ee14-4.19.1


References:

https://www.suse.com/security/cve/CVE-2020-27840.html
https://www.suse.com/security/cve/CVE-2021-20254.html
https://www.suse.com/security/cve/CVE-2021-20277.html
https://bugzilla.suse.com/1178469
https://bugzilla.suse.com/1179156
https://bugzilla.suse.com/1183572
https://bugzilla.suse.com/1183574
https://bugzilla.suse.com/1184310
https://bugzilla.suse.com/1184677
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung