Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in Exiv2
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in Exiv2
ID: USN-4941-1
Distribution: Ubuntu
Plattformen: Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 20.10, Ubuntu 21.04, Ubuntu 16.04 ESM
Datum: Mo, 10. Mai 2021, 23:11
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3482
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29457
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29458
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29470
Applikationen: ExiV2

Originalnachricht


--===============5511407234096907073==
Content-Type: multipart/signed; micalg=pgp-sha512;
protocol="application/pgp-signature";
boundary="82I3+IH0IqGh5yIs"
Content-Disposition: inline


--82I3+IH0IqGh5yIs
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

==========================================================================
Ubuntu Security Notice USN-4941-1
May 10, 2021

exiv2 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 21.04
- Ubuntu 20.10
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in Exiv2.

Software Description:
- exiv2: EXIF/IPTC/XMP metadata manipulation tool

Details:

It was discovered that Exiv2 incorrectly handled certain images.
An attacker could possibly use this issue to execute arbitrary code or cause
a crash. (CVE-2021-29457)

It was discovered that Exiv2 incorrectly handled certain images.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2021-29458, CVE-2021-29470)

It was discovered that Exiv2 incorrectly handled certain images.
An attacker could possibly use this issue to execute arbitrary code or
cause a crash. (CVE-2021-3482)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 21.04:
libexiv2-27 0.27.3-3ubuntu1.1

Ubuntu 20.10:
libexiv2-27 0.27.3-3ubuntu0.2

Ubuntu 20.04 LTS:
libexiv2-27 0.27.2-8ubuntu2.2

Ubuntu 18.04 LTS:
libexiv2-14 0.25-3.1ubuntu0.18.04.7

Ubuntu 16.04 ESM:
libexiv2-14 0.25-2.1ubuntu16.04.7+esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-4941-1
CVE-2021-29457, CVE-2021-29458, CVE-2021-29470, CVE-2021-3482

Package Information:
https://launchpad.net/ubuntu/+source/exiv2/0.27.3-3ubuntu1.1
https://launchpad.net/ubuntu/+source/exiv2/0.27.3-3ubuntu0.2
https://launchpad.net/ubuntu/+source/exiv2/0.27.2-8ubuntu2.2
https://launchpad.net/ubuntu/+source/exiv2/0.25-3.1ubuntu0.18.04.7

--82I3+IH0IqGh5yIs
Content-Type: application/pgp-signature; name="signature.asc"

-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEf+ebRFcoyOoAQoOeRbznW4QLH2kFAmCZiEIACgkQRbznW4QL
H2k0sBAAmMUmmT+N7ggdLJGhVhvFRez15Q3ktN418i/CC1ZLzpmZledSFditEstq
YMIGJw7MsmPf7jDh4J+EDvXSxuAKSoRxncx6/y5Dq7J1gGwKPcSLPbRvS9idaGGj
O+7IKKBCKoIYKd7L3n4uvasuGB3/uzgdAgcb2gVGZeYIYXc8CXpSBP510A787MWI
s2u7nkt+WArpVrX69ud2iTw/LAPmVfXFZmwHPjTQu7BFmDsjDO3adCtgdMzd8x92
5czi/IlAiElvi/sxXPRFGnnCw497MC/ltDwn/mNYsfjHFyueR95jIsnFEzkY6P0G
NG5bwev0Ocs9rGoSKk4BqUaxVpeGJ/RYd7KHUspJonKeYXATIyptDNsP9jtCigYZ
YwrxS6hl1cDDcCAfoZ1LMafSdfQ8K6wdyNJvJ/+optvwIbNrjHt5meICeS5qcGgc
JU112+sb19iHef3XHsa3F9D6ZcbB9Rm3KikhL48pFP2j1mF0d8QIBSNs+F2iLW4i
5i+1F9IiI3uSeWdHDV/L30iEHKZ76SY1HJsgBUG+qlYbfTDr1HIdRMwY6gWlzMm/
SXhlmArfiYBWbV4NVoDk/3oGDcYnfthNRRcf8yKh1wz1FXUrB3aZDcWmexLI5KWL
s+qfRWpPURF/NQHF3CF5G2yqR/SSCRamrvrqFoFPgbm60AmNjrA=
=/yDY
-----END PGP SIGNATURE-----

--82I3+IH0IqGh5yIs--


--===============5511407234096907073==
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: base64
Content-Disposition: inline

--
ubuntu-security-announce mailing list
ubuntu-security-announce@lists.ubuntu.com
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-security-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung