Login
Newsletter
Werbung

Sicherheit: Preisgabe von Informationen in xen
Aktuelle Meldungen Distributionen
Name: Preisgabe von Informationen in xen
ID: SUSE-SU-2021:1648-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server for SAP 12-SP4, SUSE OpenStack Cloud 9, SUSE OpenStack Cloud Crowbar 9, SUSE Linux Enterprise Server 12-SP4-LTSS
Datum: Mi, 19. Mai 2021, 23:33
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-28689
Applikationen: Xen

Originalnachricht


SUSE Security Update: Security update for xen
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:1648-1
Rating: important
References: #1183790 #1185021 #1185104 #1185196 #1185682

Cross-References: CVE-2021-28689
CVSS scores:
CVE-2021-28689 (SUSE): 5.9
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N

Affected Products:
SUSE OpenStack Cloud Crowbar 9
SUSE OpenStack Cloud 9
SUSE Linux Enterprise Server for SAP 12-SP4
SUSE Linux Enterprise Server 12-SP4-LTSS
______________________________________________________________________________

An update that solves one vulnerability and has four fixes
is now available.

Description:

This update for xen fixes the following issues:

Security issue fixed:

- CVE-2021-28689: Fixed some x86 speculative vulnerabilities with bare
(non-shim) 32-bit PV guests (XSA-370) (bsc#1185104)

- Make sure xencommons is in a format as expected by fillup. (bsc#1185682)

Each comment needs to be followed by an enabled key. Otherwise fillup
will remove manually enabled key=value pairs, along with everything that
looks like a stale comment, during next pkg update

- A recent systemd update caused a regression in xenstored.service systemd
now fails to track units that use systemd-notify (bsc#1183790)
- Added a delay between the call to systemd-notify and the final exit
of the wrapper script (bsc#1185021, bsc#1185196)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE OpenStack Cloud Crowbar 9:

zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2021-1648=1

- SUSE OpenStack Cloud 9:

zypper in -t patch SUSE-OpenStack-Cloud-9-2021-1648=1

- SUSE Linux Enterprise Server for SAP 12-SP4:

zypper in -t patch SUSE-SLE-SAP-12-SP4-2021-1648=1

- SUSE Linux Enterprise Server 12-SP4-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2021-1648=1



Package List:

- SUSE OpenStack Cloud Crowbar 9 (x86_64):

xen-4.11.4_18-2.54.1
xen-debugsource-4.11.4_18-2.54.1
xen-doc-html-4.11.4_18-2.54.1
xen-libs-32bit-4.11.4_18-2.54.1
xen-libs-4.11.4_18-2.54.1
xen-libs-debuginfo-32bit-4.11.4_18-2.54.1
xen-libs-debuginfo-4.11.4_18-2.54.1
xen-tools-4.11.4_18-2.54.1
xen-tools-debuginfo-4.11.4_18-2.54.1
xen-tools-domU-4.11.4_18-2.54.1
xen-tools-domU-debuginfo-4.11.4_18-2.54.1

- SUSE OpenStack Cloud 9 (x86_64):

xen-4.11.4_18-2.54.1
xen-debugsource-4.11.4_18-2.54.1
xen-doc-html-4.11.4_18-2.54.1
xen-libs-32bit-4.11.4_18-2.54.1
xen-libs-4.11.4_18-2.54.1
xen-libs-debuginfo-32bit-4.11.4_18-2.54.1
xen-libs-debuginfo-4.11.4_18-2.54.1
xen-tools-4.11.4_18-2.54.1
xen-tools-debuginfo-4.11.4_18-2.54.1
xen-tools-domU-4.11.4_18-2.54.1
xen-tools-domU-debuginfo-4.11.4_18-2.54.1

- SUSE Linux Enterprise Server for SAP 12-SP4 (x86_64):

xen-4.11.4_18-2.54.1
xen-debugsource-4.11.4_18-2.54.1
xen-doc-html-4.11.4_18-2.54.1
xen-libs-32bit-4.11.4_18-2.54.1
xen-libs-4.11.4_18-2.54.1
xen-libs-debuginfo-32bit-4.11.4_18-2.54.1
xen-libs-debuginfo-4.11.4_18-2.54.1
xen-tools-4.11.4_18-2.54.1
xen-tools-debuginfo-4.11.4_18-2.54.1
xen-tools-domU-4.11.4_18-2.54.1
xen-tools-domU-debuginfo-4.11.4_18-2.54.1

- SUSE Linux Enterprise Server 12-SP4-LTSS (x86_64):

xen-4.11.4_18-2.54.1
xen-debugsource-4.11.4_18-2.54.1
xen-doc-html-4.11.4_18-2.54.1
xen-libs-32bit-4.11.4_18-2.54.1
xen-libs-4.11.4_18-2.54.1
xen-libs-debuginfo-32bit-4.11.4_18-2.54.1
xen-libs-debuginfo-4.11.4_18-2.54.1
xen-tools-4.11.4_18-2.54.1
xen-tools-debuginfo-4.11.4_18-2.54.1
xen-tools-domU-4.11.4_18-2.54.1
xen-tools-domU-debuginfo-4.11.4_18-2.54.1


References:

https://www.suse.com/security/cve/CVE-2021-28689.html
https://bugzilla.suse.com/1183790
https://bugzilla.suse.com/1185021
https://bugzilla.suse.com/1185104
https://bugzilla.suse.com/1185196
https://bugzilla.suse.com/1185682
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung