Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in djvulibre
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in djvulibre
ID: SUSE-SU-2021:1645-1
Distribution: SUSE
Plattformen: SUSE OpenStack Cloud Crowbar 8, SUSE HPE Helion Openstack 8, SUSE OpenStack Cloud 8, SUSE Linux Enterprise Server for SAP 12-SP3, SUSE Linux Enterprise Server 12-SP2-BCL, SUSE Linux Enterprise Server for SAP 12-SP4, SUSE OpenStack Cloud 9, SUSE OpenStack Cloud Crowbar 9, SUSE Linux Enterprise Server 12-SP3-LTSS, SUSE Linux Enterprise Server 12-SP5, SUSE Linux Enterprise Software Development Kit 12-SP5, SUSE Linux Enterprise Server 12-SP3-BCL, SUSE Linux Enterprise Server 12-SP4-LTSS
Datum: Mi, 19. Mai 2021, 23:34
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-32493
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-32491
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-18804
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-32492
Applikationen: DjVuLibre

Originalnachricht


SUSE Security Update: Security update for djvulibre
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:1645-1
Rating: important
References: #1185900 #1185904 #1185905
Cross-References: CVE-2019-18804 CVE-2021-32491 CVE-2021-32492
CVE-2021-32493
CVSS scores:
CVE-2019-18804 (NVD) : 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2019-18804 (SUSE): 3.3
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L
CVE-2021-32491 (SUSE): 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2021-32492 (SUSE): 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2021-32493 (SUSE): 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
SUSE OpenStack Cloud Crowbar 9
SUSE OpenStack Cloud Crowbar 8
SUSE OpenStack Cloud 9
SUSE OpenStack Cloud 8
SUSE Linux Enterprise Software Development Kit 12-SP5
SUSE Linux Enterprise Server for SAP 12-SP4
SUSE Linux Enterprise Server for SAP 12-SP3
SUSE Linux Enterprise Server 12-SP5
SUSE Linux Enterprise Server 12-SP4-LTSS
SUSE Linux Enterprise Server 12-SP3-LTSS
SUSE Linux Enterprise Server 12-SP3-BCL
SUSE Linux Enterprise Server 12-SP2-BCL
HPE Helion Openstack 8
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:

This update for djvulibre fixes the following issues:

Security issues fixed:

- CVE-2021-32491 [bsc#1185900]: Integer overflow in function render() in
tools/ddjvu via crafted djvu file
- CVE-2021-32492 [bsc#1185904]: Out of bounds read in function
DJVU:DataPool:has_data() via crafted djvu file
- CVE-2021-32493 [bsc#1185905]: Heap buffer overflow in function
DJVU:GBitmap:decode() via crafted djvu file


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE OpenStack Cloud Crowbar 9:

zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2021-1645=1

- SUSE OpenStack Cloud Crowbar 8:

zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-8-2021-1645=1

- SUSE OpenStack Cloud 9:

zypper in -t patch SUSE-OpenStack-Cloud-9-2021-1645=1

- SUSE OpenStack Cloud 8:

zypper in -t patch SUSE-OpenStack-Cloud-8-2021-1645=1

- SUSE Linux Enterprise Software Development Kit 12-SP5:

zypper in -t patch SUSE-SLE-SDK-12-SP5-2021-1645=1

- SUSE Linux Enterprise Server for SAP 12-SP4:

zypper in -t patch SUSE-SLE-SAP-12-SP4-2021-1645=1

- SUSE Linux Enterprise Server for SAP 12-SP3:

zypper in -t patch SUSE-SLE-SAP-12-SP3-2021-1645=1

- SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2021-1645=1

- SUSE Linux Enterprise Server 12-SP4-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2021-1645=1

- SUSE Linux Enterprise Server 12-SP3-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-2021-1645=1

- SUSE Linux Enterprise Server 12-SP3-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP3-BCL-2021-1645=1

- SUSE Linux Enterprise Server 12-SP2-BCL:

zypper in -t patch SUSE-SLE-SERVER-12-SP2-BCL-2021-1645=1

- HPE Helion Openstack 8:

zypper in -t patch HPE-Helion-OpenStack-8-2021-1645=1



Package List:

- SUSE OpenStack Cloud Crowbar 9 (x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE OpenStack Cloud Crowbar 8 (x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE OpenStack Cloud 9 (x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE OpenStack Cloud 8 (x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE Linux Enterprise Software Development Kit 12-SP5 (aarch64 ppc64le
s390x x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre-devel-3.5.25.3-5.9.1

- SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE Linux Enterprise Server for SAP 12-SP3 (ppc64le x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE Linux Enterprise Server 12-SP3-LTSS (aarch64 ppc64le s390x x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE Linux Enterprise Server 12-SP3-BCL (x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- SUSE Linux Enterprise Server 12-SP2-BCL (x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1

- HPE Helion Openstack 8 (x86_64):

djvulibre-debuginfo-3.5.25.3-5.9.1
djvulibre-debugsource-3.5.25.3-5.9.1
libdjvulibre21-3.5.25.3-5.9.1
libdjvulibre21-debuginfo-3.5.25.3-5.9.1


References:

https://www.suse.com/security/cve/CVE-2019-18804.html
https://www.suse.com/security/cve/CVE-2021-32491.html
https://www.suse.com/security/cve/CVE-2021-32492.html
https://www.suse.com/security/cve/CVE-2021-32493.html
https://bugzilla.suse.com/1185900
https://bugzilla.suse.com/1185904
https://bugzilla.suse.com/1185905
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung