Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in Linux (Live Patch 14 SLE 15 SP1)
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in Linux (Live Patch 14 SLE 15 SP1)
ID: SUSE-SU-2021:1724-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Live Patching 15-SP1, SUSE Linux Enterprise Live Patching 12-SP5
Datum: Di, 25. Mai 2021, 21:35
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-29154
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-36322
Applikationen: Linux

Originalnachricht


SUSE Security Update: Security update for the Linux Kernel (Live Patch 14
for SLE 15 SP1)
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:1724-1
Rating: important
References: #1183452 #1184710 #1184952
Cross-References: CVE-2020-36322 CVE-2021-29154
CVSS scores:
CVE-2020-36322 (SUSE): 7.7
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
CVE-2021-29154 (NVD) : 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE-2021-29154 (SUSE): 7
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
SUSE Linux Enterprise Module for Live Patching 15-SP1
SUSE Linux Enterprise Live Patching 12-SP5
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for the Linux Kernel 4.12.14-197_51 fixes several issues.

The following security issues were fixed:

- CVE-2020-36322: Fixed an issue inside the FUSE filesystem implementation
where fuse_do_getattr() calls make_bad_inode() in inappropriate
situations, could have caused a system crash. NOTE: the original fix for
this vulnerability was incomplete, and its incompleteness is tracked as
CVE-2021-28950 (bsc#1184952).
- CVE-2021-29154: Fixed BPF JIT compilers that allowed to execute
arbitrary code within the kernel context (bsc#1184710)
- Fix system crash on kernfs_kill_sb() as a sysfs superblock's
kernfs_super_info node list was NULL (bsc#1183452).


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Module for Live Patching 15-SP1:

zypper in -t patch SUSE-SLE-Module-Live-Patching-15-SP1-2021-1717=1
SUSE-SLE-Module-Live-Patching-15-SP1-2021-1718=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1719=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1720=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1721=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1722=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1723=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1724=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1725=1 SUSE-SLE-Module-Live-Patching-15-SP1-2021-1726=1

- SUSE Linux Enterprise Live Patching 12-SP5:

zypper in -t patch SUSE-SLE-Live-Patching-12-SP5-2021-1735=1
SUSE-SLE-Live-Patching-12-SP5-2021-1736=1 SUSE-SLE-Live-Patching-12-SP5-2021-1737=1 SUSE-SLE-Live-Patching-12-SP5-2021-1738=1 SUSE-SLE-Live-Patching-12-SP5-2021-1739=1 SUSE-SLE-Live-Patching-12-SP5-2021-1740=1 SUSE-SLE-Live-Patching-12-SP5-2021-1741=1 SUSE-SLE-Live-Patching-12-SP5-2021-1742=1 SUSE-SLE-Live-Patching-12-SP5-2021-1743=1 SUSE-SLE-Live-Patching-12-SP5-2021-1744=1 SUSE-SLE-Live-Patching-12-SP5-2021-1745=1



Package List:

- SUSE Linux Enterprise Module for Live Patching 15-SP1 (ppc64le x86_64):

kernel-livepatch-4_12_14-197_45-default-10-2.2
kernel-livepatch-4_12_14-197_48-default-10-2.2
kernel-livepatch-4_12_14-197_51-default-10-2.2
kernel-livepatch-4_12_14-197_56-default-9-2.2
kernel-livepatch-4_12_14-197_61-default-8-2.2
kernel-livepatch-4_12_14-197_64-default-7-2.2
kernel-livepatch-4_12_14-197_67-default-7-2.2
kernel-livepatch-4_12_14-197_72-default-6-2.2
kernel-livepatch-4_12_14-197_75-default-6-2.2
kernel-livepatch-4_12_14-197_78-default-6-2.2

- SUSE Linux Enterprise Live Patching 12-SP5 (ppc64le s390x x86_64):

kgraft-patch-4_12_14-122_23-default-12-2.2
kgraft-patch-4_12_14-122_26-default-12-2.2
kgraft-patch-4_12_14-122_29-default-12-2.2
kgraft-patch-4_12_14-122_32-default-12-2.2
kgraft-patch-4_12_14-122_37-default-11-2.2
kgraft-patch-4_12_14-122_41-default-10-2.2
kgraft-patch-4_12_14-122_46-default-8-2.2
kgraft-patch-4_12_14-122_51-default-8-2.2
kgraft-patch-4_12_14-122_54-default-6-2.2
kgraft-patch-4_12_14-122_57-default-6-2.2
kgraft-patch-4_12_14-122_60-default-5-2.2


References:

https://www.suse.com/security/cve/CVE-2020-36322.html
https://www.suse.com/security/cve/CVE-2021-29154.html
https://bugzilla.suse.com/1183452
https://bugzilla.suse.com/1184710
https://bugzilla.suse.com/1184952
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung