Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in Smarty
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in Smarty
ID: 202105-06
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mi, 26. Mai 2021, 23:00
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2021-26119
https://nvd.nist.gov/vuln/detail/CVE-2021-26120
Applikationen: Smarty PHP template engine

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--zf4U5Ht8sAi6wXMTCT8eO2MVR9JXb7OxQ
Content-Type: multipart/mixed;
boundary="5x2bdceF3FyVTTMiZkR84WIgf890fcmNM";
protected-headers="v1"
From: Thomas Deutschmann <whissi@gentoo.org>
Reply-To: security@gentoo.org
To: gentoo-announce@lists.gentoo.org
Message-ID: <960aede7-a542-f4bf-f101-8808e52a163f@gentoo.org>
Subject: [ GLSA 202105-06 ] Smarty: Multiple vulnerabilities

--5x2bdceF3FyVTTMiZkR84WIgf890fcmNM
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Language: en-U
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202105-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Smarty: Multiple vulnerabilities
Date: May 26, 2021
Bugs: #772206
ID: 202105-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities in the Smarty template engine might allow
remote attackers to execute arbitrary PHP code.

Background
==========

Smarty is a template engine for PHP.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-php/smarty < 3.1.39 >= 3.1.39

Description
===========

Multiple vulnerabilities have been discovered in Smarty template
engine. Please review the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Smarty template engine users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-php/smarty-3.1.39"

References
==========

[ 1 ] CVE-2021-26119
https://nvd.nist.gov/vuln/detail/CVE-2021-26119
[ 2 ] CVE-2021-26120
https://nvd.nist.gov/vuln/detail/CVE-2021-26120

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202105-06

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5


--5x2bdceF3FyVTTMiZkR84WIgf890fcmNM--

--zf4U5Ht8sAi6wXMTCT8eO2MVR9JXb7OxQ
Content-Type: application/pgp-signature; name="OpenPGP_signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="OpenPGP_signature"

-----BEGIN PGP SIGNATURE-----

wsB5BAABCAAjFiEEExKRzo+LDXJgXHuURObr3Jv2BVkFAmCuAHwFAwAAAAAACgkQRObr3Jv2BVlj
9wf+MPKVqS3ACh7bSR4zx5RGCD0pN94Kcbg55Q4CpVOQobba4zuw66OTPftRNuhZV1vZpYMbTqY8
qIsBkOInZxWwW0sVAIYf6G6jRv7jt1Vla1pG30GPTOX5vF4PPRMKHb37VP6uvL7GBjYhe6vMsAwG
0KZ4WKX3868kVWA159SqMHRn72b+Q40HTnU0eq3zqBBpecoXCWBe2l09LZSEaM7Cf/54IuuGFxpJ
AHCH7AWw+EB5aEIEko1VyDB38c7iC7UoaZn1z6VWD8fLWgOEubzPgPlxmQ1/pzSB6FEQw6x84YKA
I8EAaGKuyNl4L42TQw1crQoO1G6lp8o0UdoMIhYQQA==
=U36D
-----END PGP SIGNATURE-----

--zf4U5Ht8sAi6wXMTCT8eO2MVR9JXb7OxQ--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung