Login
Newsletter
Werbung

Sicherheit: Denial of Service in Tar
Aktuelle Meldungen Distributionen
Name: Denial of Service in Tar
ID: 202105-29
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mi, 26. Mai 2021, 23:03
Referenzen: https://nvd.nist.gov/vuln/detail/CVE-2021-20193
Applikationen: GNU Tar

Originalnachricht

This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--SMjCueiZFTCDHujbv0FfgDUnDCU1fuKeQ
Content-Type: multipart/mixed;
boundary="m4G19Lk2G13TMjZFhC3NM1cTlJqcAnOQB";
protected-headers="v1"
From: Thomas Deutschmann <whissi@gentoo.org>
Reply-To: security@gentoo.org
To: gentoo-announce@lists.gentoo.org
Message-ID: <aa27fcbe-c5f9-ee54-fb6c-2e4f4f76642a@gentoo.org>
Subject: [ GLSA 202105-29 ] Tar: Denial of service

--m4G19Lk2G13TMjZFhC3NM1cTlJqcAnOQB
Content-Type: text/plain; charset=utf-8; format=flowed
Content-Language: en-U
Content-Transfer-Encoding: quoted-printable

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202105-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low
Title: Tar: Denial of service
Date: May 26, 2021
Bugs: #778548
ID: 202105-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability in Tar could lead to a Denial of Service condition.

Background
==========

The Tar program provides the ability to create and manipulate tar
archives.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-arch/tar < 1.34 >= 1.34

Description
===========

It was discovered that GNU Tar had a memory leak when processing
archive headers.

Impact
======

A remote attacker could entice a user to open a specially crafted
archive using Tar, possibly resulting in a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Tar users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-arch/tar-1.34"

References
==========

[ 1 ] CVE-2021-20193
https://nvd.nist.gov/vuln/detail/CVE-2021-20193

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202105-29

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2021 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5


--m4G19Lk2G13TMjZFhC3NM1cTlJqcAnOQB--

--SMjCueiZFTCDHujbv0FfgDUnDCU1fuKeQ
Content-Type: application/pgp-signature; name="OpenPGP_signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="OpenPGP_signature"

-----BEGIN PGP SIGNATURE-----

wsB5BAABCAAjFiEEExKRzo+LDXJgXHuURObr3Jv2BVkFAmCuH6MFAwAAAAAACgkQRObr3Jv2BVlz
0wf/Ufnz3wiWxAKOIAxiPWbRy/7xbR3zpgqrklHndc8EK+Uog/KDG3B2wRIG+nV+mLEneF1CYFBx
xsCwGO++PKeTLRId91hUpiQ4+t9tZKz1Etmi7FkWlKIsvgVqmQuUfWIEXekF9eCUmQwq600E1u+q
xGQB2pkviLy+69MqTaG1RALRcCZVd+Kwl2WxQ8z4nCMSybQsb2DjUmzaprmGVoW9LwG5NpMFOZzP
nOjC/qBCgf49abAYWzX6PO6z5ncj3tbu6BwJaaJTJU/tXgPoKa+pL8Th8hcG3NGgSO9kjABF+jG3
yqQFmKI1hysiEEXLUZH4VdMxWnCillXTzjSm1j1hKg==
=mrWG
-----END PGP SIGNATURE-----

--SMjCueiZFTCDHujbv0FfgDUnDCU1fuKeQ--
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung