Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in slurm
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in slurm
ID: SUSE-SU-2021:1855-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise High Performance Computing 15-ESPOS, SUSE Linux Enterprise High Performance Computing 15-LTSS, SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS, SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS
Datum: Sa, 5. Juni 2021, 00:13
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-31215
Applikationen: slurm

Originalnachricht


SUSE Security Update: Security update for slurm
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:1855-1
Rating: important
References: #1186024
Cross-References: CVE-2021-31215
CVSS scores:
CVE-2021-31215 (NVD) : 8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE-2021-31215 (SUSE): 8.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Affected Products:
SUSE Linux Enterprise High Performance Computing
15-SP1-LTSS
SUSE Linux Enterprise High Performance Computing
15-SP1-ESPOS
SUSE Linux Enterprise High Performance Computing 15-LTSS
SUSE Linux Enterprise High Performance Computing 15-ESPOS
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for slurm fixes the following issues:

- CVE-2021-31215: remote code execution as SlurmUser because of a
PrologSlurmctld or EpilogSlurmctld script leads to environment
mishandling (bsc#1186024)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-1855=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-1855=1

- SUSE Linux Enterprise High Performance Computing 15-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2021-1855=1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-2021-1855=1



Package List:

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (aarch64
x86_64):

libslurm32-17.11.13-6.37.1
libslurm32-debuginfo-17.11.13-6.37.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (aarch64
x86_64):

libslurm32-17.11.13-6.37.1
libslurm32-debuginfo-17.11.13-6.37.1

- SUSE Linux Enterprise High Performance Computing 15-LTSS (aarch64 x86_64):

libpmi0-17.11.13-6.37.1
libpmi0-debuginfo-17.11.13-6.37.1
libslurm32-17.11.13-6.37.1
libslurm32-debuginfo-17.11.13-6.37.1
perl-slurm-17.11.13-6.37.1
perl-slurm-debuginfo-17.11.13-6.37.1
slurm-17.11.13-6.37.1
slurm-auth-none-17.11.13-6.37.1
slurm-auth-none-debuginfo-17.11.13-6.37.1
slurm-config-17.11.13-6.37.1
slurm-debuginfo-17.11.13-6.37.1
slurm-debugsource-17.11.13-6.37.1
slurm-devel-17.11.13-6.37.1
slurm-doc-17.11.13-6.37.1
slurm-lua-17.11.13-6.37.1
slurm-lua-debuginfo-17.11.13-6.37.1
slurm-munge-17.11.13-6.37.1
slurm-munge-debuginfo-17.11.13-6.37.1
slurm-node-17.11.13-6.37.1
slurm-node-debuginfo-17.11.13-6.37.1
slurm-pam_slurm-17.11.13-6.37.1
slurm-pam_slurm-debuginfo-17.11.13-6.37.1
slurm-plugins-17.11.13-6.37.1
slurm-plugins-debuginfo-17.11.13-6.37.1
slurm-slurmdbd-17.11.13-6.37.1
slurm-slurmdbd-debuginfo-17.11.13-6.37.1
slurm-sql-17.11.13-6.37.1
slurm-sql-debuginfo-17.11.13-6.37.1
slurm-torque-17.11.13-6.37.1
slurm-torque-debuginfo-17.11.13-6.37.1

- SUSE Linux Enterprise High Performance Computing 15-ESPOS (aarch64
x86_64):

libpmi0-17.11.13-6.37.1
libpmi0-debuginfo-17.11.13-6.37.1
libslurm32-17.11.13-6.37.1
libslurm32-debuginfo-17.11.13-6.37.1
perl-slurm-17.11.13-6.37.1
perl-slurm-debuginfo-17.11.13-6.37.1
slurm-17.11.13-6.37.1
slurm-auth-none-17.11.13-6.37.1
slurm-auth-none-debuginfo-17.11.13-6.37.1
slurm-config-17.11.13-6.37.1
slurm-debuginfo-17.11.13-6.37.1
slurm-debugsource-17.11.13-6.37.1
slurm-devel-17.11.13-6.37.1
slurm-doc-17.11.13-6.37.1
slurm-lua-17.11.13-6.37.1
slurm-lua-debuginfo-17.11.13-6.37.1
slurm-munge-17.11.13-6.37.1
slurm-munge-debuginfo-17.11.13-6.37.1
slurm-node-17.11.13-6.37.1
slurm-node-debuginfo-17.11.13-6.37.1
slurm-pam_slurm-17.11.13-6.37.1
slurm-pam_slurm-debuginfo-17.11.13-6.37.1
slurm-plugins-17.11.13-6.37.1
slurm-plugins-debuginfo-17.11.13-6.37.1
slurm-slurmdbd-17.11.13-6.37.1
slurm-slurmdbd-debuginfo-17.11.13-6.37.1
slurm-sql-17.11.13-6.37.1
slurm-sql-debuginfo-17.11.13-6.37.1
slurm-torque-17.11.13-6.37.1
slurm-torque-debuginfo-17.11.13-6.37.1


References:

https://www.suse.com/security/cve/CVE-2021-31215.html
https://bugzilla.suse.com/1186024
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung