Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in qemu
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in qemu
ID: SUSE-SU-2021:1893-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Module for Server Applications 15-SP2, SUSE MicroOS 5.0
Datum: Di, 8. Juni 2021, 21:52
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-20257
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8608
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25707
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25085
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-29129
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-15890
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-10756
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-25723
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-29130
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-3419
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-14364
Applikationen: QEMU

Originalnachricht


SUSE Security Update: Security update for qemu
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:1893-1
Rating: important
References: #1149813 #1163019 #1172380 #1175534 #1176681
#1178683 #1178935 #1179477 #1179484 #1182846
#1182975 #1183979 #1186290 SLE-17785
Cross-References: CVE-2019-15890 CVE-2020-10756 CVE-2020-14364
CVE-2020-25085 CVE-2020-25707 CVE-2020-25723
CVE-2020-29129 CVE-2020-29130 CVE-2020-8608
CVE-2021-20257 CVE-2021-3419
CVSS scores:
CVE-2019-15890 (SUSE): 5.8
CVSS:3.0/AV:A/AC:H/PR:L/UI:N/S:C/C:N/I:N/A:H
CVE-2020-10756 (NVD) : 6.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
CVE-2020-10756 (SUSE): 6.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
CVE-2020-14364 (NVD) : 5
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L
CVE-2020-14364 (SUSE): 5
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L
CVE-2020-25085 (NVD) : 5
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L
CVE-2020-25085 (SUSE): 5
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:L/I:L/A:L
CVE-2020-25707 (SUSE): 6
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
CVE-2020-25723 (NVD) : 3.2
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
CVE-2020-25723 (SUSE): 3.2
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
CVE-2020-29129 (NVD) : 4.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVE-2020-29129 (SUSE): 2.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
CVE-2020-29130 (NVD) : 4.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVE-2020-29130 (SUSE): 4.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
CVE-2020-8608 (NVD) : 5.6
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
CVE-2020-8608 (SUSE): 7
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:H
CVE-2021-20257 (SUSE): 3.2
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:L
CVE-2021-3419 (SUSE): 5.5
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected Products:
SUSE MicroOS 5.0
SUSE Linux Enterprise Module for Server Applications 15-SP2
SUSE Linux Enterprise Module for Basesystem 15-SP2
______________________________________________________________________________

An update that solves 11 vulnerabilities, contains one
feature and has two fixes is now available.

Description:

This update for qemu fixes the following issues:

- CVE-2020-25085: Fix out-of-bounds access issue while doing multi block
SDMA (bsc#1176681)
- CVE-2020-10756: Fix out-of-bounds read information disclosure in
icmp6_send_echoreply(bsc#1172380)
- Fix issue where s390 guest fails to find zipl boot menu index
(bsc#1183979)
- QEMU BIOS fails to read stage2 loader on s390x (bsc#1186290)
- Host CPU microcode revision will be visible inside VMs when the proper
CPU-model is used (jsc#SLE-17785):
- For the record, these issues are fixed in this package already. Most are
alternate references to previously mentioned issues: (CVE-2019-15890,
bsc#1149813, CVE-2020-8608, bsc#1163019, CVE-2020-14364, bsc#1175534,
CVE-2020-25707, bsc#1178683, CVE-2020-25723, bsc#1178935,
CVE-2020-29130, bsc#1179477, CVE-2020-29129, bsc#1179484,
CVE-2021-20257, bsc#1182846, CVE-2021-3419, bsc#1182975)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE MicroOS 5.0:

zypper in -t patch SUSE-SUSE-MicroOS-5.0-2021-1893=1

- SUSE Linux Enterprise Module for Server Applications 15-SP2:

zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP2-2021-1893=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-1893=1



Package List:

- SUSE MicroOS 5.0 (aarch64 x86_64):

qemu-4.2.1-11.19.2
qemu-debuginfo-4.2.1-11.19.2
qemu-debugsource-4.2.1-11.19.2
qemu-tools-4.2.1-11.19.2
qemu-tools-debuginfo-4.2.1-11.19.2

- SUSE MicroOS 5.0 (aarch64):

qemu-arm-4.2.1-11.19.2
qemu-arm-debuginfo-4.2.1-11.19.2

- SUSE MicroOS 5.0 (x86_64):

qemu-x86-4.2.1-11.19.2
qemu-x86-debuginfo-4.2.1-11.19.2

- SUSE MicroOS 5.0 (noarch):

qemu-ipxe-1.0.0+-11.19.2
qemu-seabios-1.12.1+-11.19.2
qemu-sgabios-8-11.19.2
qemu-vgabios-1.12.1+-11.19.2

- SUSE Linux Enterprise Module for Server Applications 15-SP2 (aarch64
ppc64le s390x x86_64):

qemu-4.2.1-11.19.2
qemu-block-curl-4.2.1-11.19.2
qemu-block-curl-debuginfo-4.2.1-11.19.2
qemu-block-iscsi-4.2.1-11.19.2
qemu-block-iscsi-debuginfo-4.2.1-11.19.2
qemu-block-rbd-4.2.1-11.19.2
qemu-block-rbd-debuginfo-4.2.1-11.19.2
qemu-block-ssh-4.2.1-11.19.2
qemu-block-ssh-debuginfo-4.2.1-11.19.2
qemu-debuginfo-4.2.1-11.19.2
qemu-debugsource-4.2.1-11.19.2
qemu-guest-agent-4.2.1-11.19.2
qemu-guest-agent-debuginfo-4.2.1-11.19.2
qemu-lang-4.2.1-11.19.2
qemu-ui-spice-app-4.2.1-11.19.2
qemu-ui-spice-app-debuginfo-4.2.1-11.19.2

- SUSE Linux Enterprise Module for Server Applications 15-SP2 (s390x
x86_64):

qemu-kvm-4.2.1-11.19.2

- SUSE Linux Enterprise Module for Server Applications 15-SP2 (ppc64le):

qemu-ppc-4.2.1-11.19.2
qemu-ppc-debuginfo-4.2.1-11.19.2

- SUSE Linux Enterprise Module for Server Applications 15-SP2 (aarch64):

qemu-arm-4.2.1-11.19.2
qemu-arm-debuginfo-4.2.1-11.19.2

- SUSE Linux Enterprise Module for Server Applications 15-SP2 (x86_64):

qemu-audio-alsa-4.2.1-11.19.2
qemu-audio-alsa-debuginfo-4.2.1-11.19.2
qemu-audio-pa-4.2.1-11.19.2
qemu-audio-pa-debuginfo-4.2.1-11.19.2
qemu-ui-curses-4.2.1-11.19.2
qemu-ui-curses-debuginfo-4.2.1-11.19.2
qemu-ui-gtk-4.2.1-11.19.2
qemu-ui-gtk-debuginfo-4.2.1-11.19.2
qemu-x86-4.2.1-11.19.2
qemu-x86-debuginfo-4.2.1-11.19.2

- SUSE Linux Enterprise Module for Server Applications 15-SP2 (noarch):

qemu-ipxe-1.0.0+-11.19.2
qemu-microvm-4.2.1-11.19.2
qemu-seabios-1.12.1+-11.19.2
qemu-sgabios-8-11.19.2
qemu-vgabios-1.12.1+-11.19.2

- SUSE Linux Enterprise Module for Server Applications 15-SP2 (s390x):

qemu-s390-4.2.1-11.19.2
qemu-s390-debuginfo-4.2.1-11.19.2

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 ppc64le s390x
x86_64):

qemu-debuginfo-4.2.1-11.19.2
qemu-debugsource-4.2.1-11.19.2
qemu-tools-4.2.1-11.19.2
qemu-tools-debuginfo-4.2.1-11.19.2


References:

https://www.suse.com/security/cve/CVE-2019-15890.html
https://www.suse.com/security/cve/CVE-2020-10756.html
https://www.suse.com/security/cve/CVE-2020-14364.html
https://www.suse.com/security/cve/CVE-2020-25085.html
https://www.suse.com/security/cve/CVE-2020-25707.html
https://www.suse.com/security/cve/CVE-2020-25723.html
https://www.suse.com/security/cve/CVE-2020-29129.html
https://www.suse.com/security/cve/CVE-2020-29130.html
https://www.suse.com/security/cve/CVE-2020-8608.html
https://www.suse.com/security/cve/CVE-2021-20257.html
https://www.suse.com/security/cve/CVE-2021-3419.html
https://bugzilla.suse.com/1149813
https://bugzilla.suse.com/1163019
https://bugzilla.suse.com/1172380
https://bugzilla.suse.com/1175534
https://bugzilla.suse.com/1176681
https://bugzilla.suse.com/1178683
https://bugzilla.suse.com/1178935
https://bugzilla.suse.com/1179477
https://bugzilla.suse.com/1179484
https://bugzilla.suse.com/1182846
https://bugzilla.suse.com/1182975
https://bugzilla.suse.com/1183979
https://bugzilla.suse.com/1186290
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung