Login
Newsletter
Werbung

Sicherheit: Preisgabe von Informationen in python-rsa
Aktuelle Meldungen Distributionen
Name: Preisgabe von Informationen in python-rsa
ID: SUSE-SU-2021:2008-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Public Cloud 15, SUSE Enterprise Storage 6, SUSE CaaS Platform 4.0, SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2, SUSE Linux Enterprise Module for Basesystem 15-SP3, SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3, SUSE Linux Enterprise Server for SAP 15-SP1, SUSE Manager Server 4.0, SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS, SUSE Linux Enterprise Server 15-SP1-LTSS, SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS, SUSE Manager Proxy 4.0, SUSE Manager Retail Branch Server 4.0, SUSE Linux Enterprise Server 15-SP1-BCL
Datum: Do, 17. Juni 2021, 21:57
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-13757
Applikationen: python-rsa

Originalnachricht


SUSE Security Update: Security update for python-rsa
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:2008-1
Rating: important
References: #1172389
Cross-References: CVE-2020-13757
CVSS scores:
CVE-2020-13757 (NVD) : 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVE-2020-13757 (SUSE): 7.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
SUSE Manager Server 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Proxy 4.0
SUSE Linux Enterprise Server for SAP 15-SP1
SUSE Linux Enterprise Server 15-SP1-LTSS
SUSE Linux Enterprise Server 15-SP1-BCL
SUSE Linux Enterprise Module for Public Cloud 15
SUSE Linux Enterprise Module for Packagehub Subpackages
15-SP3
SUSE Linux Enterprise Module for Packagehub Subpackages
15-SP2
SUSE Linux Enterprise Module for Basesystem 15-SP3
SUSE Linux Enterprise Module for Basesystem 15-SP2
SUSE Linux Enterprise High Performance Computing
15-SP1-LTSS
SUSE Linux Enterprise High Performance Computing
15-SP1-ESPOS
SUSE Enterprise Storage 6
SUSE CaaS Platform 4.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for python-rsa fixes the following issues:

- CVE-2020-13757: Proper handling of leading '\0' bytes during
decryption
of ciphertext (bsc#1172389)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Manager Server 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-2008=1

- SUSE Manager Retail Branch Server 4.0:

zypper in -t patch
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-2008=1

- SUSE Manager Proxy 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-2008=1

- SUSE Linux Enterprise Server for SAP 15-SP1:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-2008=1

- SUSE Linux Enterprise Server 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-2008=1

- SUSE Linux Enterprise Server 15-SP1-BCL:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-2008=1

- SUSE Linux Enterprise Module for Public Cloud 15:

zypper in -t patch SUSE-SLE-Module-Public-Cloud-15-2021-2008=1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3:

zypper in -t patch
SUSE-SLE-Module-Packagehub-Subpackages-15-SP3-2021-2008=1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2:

zypper in -t patch
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2021-2008=1

- SUSE Linux Enterprise Module for Basesystem 15-SP3:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2021-2008=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-2008=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-2008=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-2008=1

- SUSE Enterprise Storage 6:

zypper in -t patch SUSE-Storage-6-2021-2008=1

- SUSE CaaS Platform 4.0:

To install this update, use the SUSE CaaS Platform 'skuba' tool.
It
will inform you if it detects new updates and let you then trigger
updating of the complete cluster in a controlled way.



Package List:

- SUSE Manager Server 4.0 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Manager Retail Branch Server 4.0 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Manager Proxy 4.0 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Server for SAP 15-SP1 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Server 15-SP1-LTSS (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Server 15-SP1-BCL (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Module for Public Cloud 15 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP3 (noarch):

python2-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Module for Packagehub Subpackages 15-SP2 (noarch):

python2-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Module for Basesystem 15-SP3 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE Enterprise Storage 6 (noarch):

python3-rsa-3.4.2-3.4.1

- SUSE CaaS Platform 4.0 (noarch):

python3-rsa-3.4.2-3.4.1


References:

https://www.suse.com/security/cve/CVE-2020-13757.html
https://bugzilla.suse.com/1172389
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung