Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in SUSE Manager Client Tools
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in SUSE Manager Client Tools
ID: SUSE-SU-2021:2111-1
Distribution: SUSE
Plattformen: SUSE Manager Debian 10-CLIENT-TOOLS
Datum: Di, 22. Juni 2021, 07:48
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-25315
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-31607
Applikationen: SUSE Manager Client Tools

Originalnachricht


SUSE Security Update: Security update for SUSE Manager Client Tools
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:2111-1
Rating: moderate
References: #1171257 #1173557 #1176293 #1179831 #1180583
#1180584 #1180585 #1181368 #1182281 #1182293
#1182382 #1185092 #1185281 #1186674 ECO-3212
SLE-18028 SLE-18033
Cross-References: CVE-2021-25315 CVE-2021-31607
CVSS scores:
CVE-2021-25315 (NVD) : 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE-2021-25315 (SUSE): 9.8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVE-2021-31607 (NVD) : 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE-2021-31607 (SUSE): 7
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:
SUSE Manager Debian 10-CLIENT-TOOLS
______________________________________________________________________________

An update that solves two vulnerabilities, contains three
features and has 12 fixes is now available.

Description:

This update fixes the following issues:

salt:

- Check if dpkgnotify is executable (bsc#1186674)
- Update to Salt release version 3002.2 (jsc#ECO-3212, jsc#SLE-18033,
jsc#SLE-18028))
- Drop support for Python2. Obsoletes `python2-salt` package
(jsc#SLE-18028)
- Virt module updates
* network: handle missing ipv4 netmask attribute
* more network support
* PCI/USB host devices passthrough support
- Set distro requirement to oldest supported version in
requirements/base.txt
- Bring missing part of async batch implementation back (bsc#1182382,
CVE-2021-25315)
- Always require python3-distro (bsc#1182293)
- Remove deprecated warning that breaks minion execution when
"server_id_use_crc" opts is missing
- Fix pkg states when DEB package has "all" arch
- Do not force beacons configuration to be a list.
- Remove msgpack < 1.0.0 from base requirements (bsc#1176293)
- Msgpack support for version >= 1.0.0 (bsc#1171257)
- Fix issue parsing errors in ansiblegate state module
- Prevent command injection in the snapper module (bsc#1185281,
CVE-2021-31607)
- Transactional_update: detect recursion in the executor
- Add subpackage salt-transactional-update (jsc#SLE-18033)
- Remove duplicate directories from specfile
- Improvements on "ansiblegate" module (bsc#1185092):
* New methods: ansible.targets / ansible.discover_playbooks
- Add support for Alibaba Cloud Linux 2 (Aliyun Linux)
- Regression fix of salt-ssh on processing targets
- Update target fix for salt-ssh and avoiding race condition on salt-ssh
event processing (bsc#1179831, bsc#1182281)
- Add notify beacon for Debian/Ubuntu systems
- Fix zmq bug that causes salt-call to freeze (bsc#1181368)

spacecmd:

- Rename system migration to system transfer
- Rename SP to product migration
- Update translation strings
- Add group_addconfigchannel and group_removeconfigchannel
- Add group_listconfigchannels and configchannel_listgroups
- Fix spacecmd compat with Python 3
- Deprecated "Software Crashes" feature
- Document advanced package search on '--help' (bsc#1180583)
- Fixed advanced search on 'package_listinstalledsystems'
- Fixed duplicate results when using multiple search criteria (bsc#1180585)
- Fixed "non-advanced" package search when using multiple package
names
(bsc#1180584)
- Update translations
- Fix: make spacecmd build on Debian
- Add Service Pack migration operations (bsc#1173557)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Manager Debian 10-CLIENT-TOOLS:

zypper in -t patch SUSE-Debian-10-CLIENT-TOOLS-x86_64-2021-2111=1



Package List:

- SUSE Manager Debian 10-CLIENT-TOOLS (all):

salt-common-3002.2+ds-1+2.27.1
salt-minion-3002.2+ds-1+2.27.1
scap-security-guide-debian-0.1.55git20210323-2.3.1
spacecmd-4.2.8-2.9.1


References:

https://www.suse.com/security/cve/CVE-2021-25315.html
https://www.suse.com/security/cve/CVE-2021-31607.html
https://bugzilla.suse.com/1171257
https://bugzilla.suse.com/1173557
https://bugzilla.suse.com/1176293
https://bugzilla.suse.com/1179831
https://bugzilla.suse.com/1180583
https://bugzilla.suse.com/1180584
https://bugzilla.suse.com/1180585
https://bugzilla.suse.com/1181368
https://bugzilla.suse.com/1182281
https://bugzilla.suse.com/1182293
https://bugzilla.suse.com/1182382
https://bugzilla.suse.com/1185092
https://bugzilla.suse.com/1185281
https://bugzilla.suse.com/1186674
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung