Login
Newsletter
Werbung

Sicherheit: Verwendung schwacher Verschlüsselung in cryptctl
Aktuelle Meldungen Distributionen
Name: Verwendung schwacher Verschlüsselung in cryptctl
ID: SUSE-SU-2021:2136-1
Distribution: SUSE
Plattformen: SUSE Enterprise Storage 6, SUSE CaaS Platform 4.0, SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Module for Basesystem 15-SP3, SUSE Linux Enterprise Server for SAP 15-SP1, SUSE Manager Server 4.0, SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS, SUSE Linux Enterprise Server 15-SP1-LTSS, SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS, SUSE Manager Proxy 4.0, SUSE Manager Retail Branch Server 4.0, SUSE Linux Enterprise Server 15-SP1-BCL, SUSE Linux Enterprise Module for SAP Applications 15, SUSE Linux Enterprise Module for SAP Applications 15-SP1
Datum: Do, 24. Juni 2021, 07:24
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-18906
Applikationen: cryptctl

Originalnachricht


SUSE Security Update: Security update for cryptctl
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:2136-1
Rating: important
References: #1186226
Cross-References: CVE-2019-18906
Affected Products:
SUSE Manager Server 4.0
SUSE Manager Retail Branch Server 4.0
SUSE Manager Proxy 4.0
SUSE Linux Enterprise Server for SAP 15-SP1
SUSE Linux Enterprise Server 15-SP1-LTSS
SUSE Linux Enterprise Server 15-SP1-BCL
SUSE Linux Enterprise Module for SAP Applications 15-SP1
SUSE Linux Enterprise Module for SAP Applications 15
SUSE Linux Enterprise Module for Basesystem 15-SP3
SUSE Linux Enterprise Module for Basesystem 15-SP2
SUSE Linux Enterprise High Performance Computing
15-SP1-LTSS
SUSE Linux Enterprise High Performance Computing
15-SP1-ESPOS
SUSE Enterprise Storage 6
SUSE CaaS Platform 4.0
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

This update for cryptctl fixes the following issues:

Update to version 2.4:

- CVE-2019-18906: Client side password hashing was equivalent to clear
text password storage (bsc#1186226)
- First step to use plain text password instead of hashed password.
- Move repository into the SUSE github organization
- in RPC server, if client comes from localhost, remember its ipv4
localhost address instead of ipv6 address
- tell a record to clear expired pending commands upon saving a command
result; introduce pending commands RPC test case
- avoid hard coding 127.0.0.1 in host ID of alive message test; let system
administrator mount and unmount disks by issuing these two commands on
key server.


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Manager Server 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Server-4.0-2021-2136=1

- SUSE Manager Retail Branch Server 4.0:

zypper in -t patch
SUSE-SLE-Product-SUSE-Manager-Retail-Branch-Server-4.0-2021-2136=1

- SUSE Manager Proxy 4.0:

zypper in -t patch SUSE-SLE-Product-SUSE-Manager-Proxy-4.0-2021-2136=1

- SUSE Linux Enterprise Server for SAP 15-SP1:

zypper in -t patch SUSE-SLE-Product-SLES_SAP-15-SP1-2021-2136=1

- SUSE Linux Enterprise Server 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-LTSS-2021-2136=1

- SUSE Linux Enterprise Server 15-SP1-BCL:

zypper in -t patch SUSE-SLE-Product-SLES-15-SP1-BCL-2021-2136=1

- SUSE Linux Enterprise Module for SAP Applications 15-SP1:

zypper in -t patch SUSE-SLE-Module-SAP-Applications-15-SP1-2021-2136=1

- SUSE Linux Enterprise Module for SAP Applications 15:

zypper in -t patch SUSE-SLE-Module-SAP-Applications-15-2021-2136=1

- SUSE Linux Enterprise Module for Basesystem 15-SP3:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2021-2136=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-2136=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-LTSS-2021-2136=1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS:

zypper in -t patch SUSE-SLE-Product-HPC-15-SP1-ESPOS-2021-2136=1

- SUSE Enterprise Storage 6:

zypper in -t patch SUSE-Storage-6-2021-2136=1

- SUSE CaaS Platform 4.0:

To install this update, use the SUSE CaaS Platform 'skuba' tool.
It
will inform you if it detects new updates and let you then trigger
updating of the complete cluster in a controlled way.



Package List:

- SUSE Manager Server 4.0 (ppc64le x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Manager Retail Branch Server 4.0 (x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Manager Proxy 4.0 (x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise Server for SAP 15-SP1 (ppc64le x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise Server 15-SP1-LTSS (ppc64le x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise Server 15-SP1-BCL (x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise Module for SAP Applications 15-SP1 (ppc64le x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise Module for SAP Applications 15 (ppc64le x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise Module for Basesystem 15-SP3 (ppc64le x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (ppc64le x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-LTSS (x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Linux Enterprise High Performance Computing 15-SP1-ESPOS (x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE Enterprise Storage 6 (x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1

- SUSE CaaS Platform 4.0 (x86_64):

cryptctl-2.4-4.5.1
cryptctl-debuginfo-2.4-4.5.1


References:

https://www.suse.com/security/cve/CVE-2019-18906.html
https://bugzilla.suse.com/1186226
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung