Login
Newsletter
Werbung

Sicherheit: Zwei Probleme in lua53
Aktuelle Meldungen Distributionen
Name: Zwei Probleme in lua53
ID: SUSE-SU-2021:2196-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Module for Basesystem 15-SP2, SUSE Linux Enterprise Module for Basesystem 15-SP3, SUSE MicroOS 5.0
Datum: Mi, 30. Juni 2021, 19:36
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24370
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24371
Applikationen: Lua

Originalnachricht


SUSE Security Update: Security update for lua53
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:2196-1
Rating: moderate
References: #1175448 #1175449
Cross-References: CVE-2020-24370 CVE-2020-24371
CVSS scores:
CVE-2020-24370 (NVD) : 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2020-24370 (SUSE): 4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2020-24371 (NVD) : 5.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
CVE-2020-24371 (SUSE): 5.1
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Affected Products:
SUSE MicroOS 5.0
SUSE Linux Enterprise Module for Basesystem 15-SP3
SUSE Linux Enterprise Module for Basesystem 15-SP2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for lua53 fixes the following issues:

Update to version 5.3.6:

- CVE-2020-24371: lgc.c mishandles the interaction between barriers and
the sweep phase, leading to a memory access violation involving
collectgarbage (bsc#1175449)
- CVE-2020-24370: ldebug.c allows a negation overflow and segmentation
fault in getlocal and setlocal (bsc#1175448)
- Long brackets with a huge number of '=' overflow some internal
buffer
arithmetic.


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE MicroOS 5.0:

zypper in -t patch SUSE-SUSE-MicroOS-5.0-2021-2196=1

- SUSE Linux Enterprise Module for Basesystem 15-SP3:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP3-2021-2196=1

- SUSE Linux Enterprise Module for Basesystem 15-SP2:

zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP2-2021-2196=1



Package List:

- SUSE MicroOS 5.0 (aarch64 x86_64):

liblua5_3-5-5.3.6-3.6.1
liblua5_3-5-debuginfo-5.3.6-3.6.1
lua53-debuginfo-5.3.6-3.6.1
lua53-debugsource-5.3.6-3.6.1

- SUSE Linux Enterprise Module for Basesystem 15-SP3 (aarch64 ppc64le s390x
x86_64):

liblua5_3-5-5.3.6-3.6.1
liblua5_3-5-debuginfo-5.3.6-3.6.1
lua53-5.3.6-3.6.1
lua53-debuginfo-5.3.6-3.6.1
lua53-debugsource-5.3.6-3.6.1
lua53-devel-5.3.6-3.6.1

- SUSE Linux Enterprise Module for Basesystem 15-SP3 (x86_64):

liblua5_3-5-32bit-5.3.6-3.6.1
liblua5_3-5-32bit-debuginfo-5.3.6-3.6.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (aarch64 ppc64le s390x
x86_64):

liblua5_3-5-5.3.6-3.6.1
liblua5_3-5-debuginfo-5.3.6-3.6.1
lua53-5.3.6-3.6.1
lua53-debuginfo-5.3.6-3.6.1
lua53-debugsource-5.3.6-3.6.1
lua53-devel-5.3.6-3.6.1

- SUSE Linux Enterprise Module for Basesystem 15-SP2 (x86_64):

liblua5_3-5-32bit-5.3.6-3.6.1
liblua5_3-5-32bit-debuginfo-5.3.6-3.6.1


References:

https://www.suse.com/security/cve/CVE-2020-24370.html
https://www.suse.com/security/cve/CVE-2020-24371.html
https://bugzilla.suse.com/1175448
https://bugzilla.suse.com/1175449
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung