Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in permissions
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in permissions
ID: SUSE-SU-2021:2280-1
Distribution: SUSE
Plattformen: SUSE Linux Enterprise Server 12-SP5
Datum: Fr, 9. Juli 2021, 23:08
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-8013
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3688
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-3690
Applikationen: permissions

Originalnachricht


SUSE Security Update: Security update for permissions
______________________________________________________________________________

Announcement ID: SUSE-SU-2021:2280-1
Rating: moderate
References: #1047247 #1050467 #1093414 #1097665 #1123886
#1150734 #1155939 #1157198 #1160594 #1160764
#1161779 #1163922 #1171883 #1182899
Cross-References: CVE-2019-3688 CVE-2019-3690 CVE-2020-8013

CVSS scores:
CVE-2019-3688 (NVD) : 7.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
CVE-2019-3688 (SUSE): 5.1
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
CVE-2019-3690 (NVD) : 7.8
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVE-2019-3690 (SUSE): 6.8
CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
CVE-2020-8013 (NVD) : 2.5
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
CVE-2020-8013 (SUSE): 6.8
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N

Affected Products:
SUSE Linux Enterprise Server 12-SP5
______________________________________________________________________________

An update that solves three vulnerabilities and has 11
fixes is now available.

Description:

This update for permissions fixes the following issues:

- Fork package for 12-SP5 (bsc#1155939)
- make btmp root:utmp (bsc#1050467, bsc#1182899)
- pcp: remove no longer needed / conflicting entries (bsc#1171883). Fixes
a potential security issue.
- do not follow symlinks that are the final path element (CVE-2020-8013,
bsc#1163922)
- fix handling of relative directory symlinks in chkstat
- whitelist postgres sticky directories (bsc#1123886)
- fix regression where chkstat breaks without /proc available
(bsc#1160764, bsc#1160594)
- fix capability handling when doing multiple permission changes at once
(bsc#1161779,
- fix invalid free() when permfiles points to argv (bsc#1157198)
- the eror should be reported for permfiles[i], not argv[i], as these are
not the same files. (bsc#1047247, bsc#1097665)
- fix /usr/sbin/pinger ownership to root:squid (bsc#1093414, CVE-2019-3688)
- fix privilege escalation through untrusted symlinks (bsc#1150734,
CVE-2019-3690)


Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation
methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 12-SP5:

zypper in -t patch SUSE-SLE-SERVER-12-SP5-2021-2280=1



Package List:

- SUSE Linux Enterprise Server 12-SP5 (aarch64 ppc64le s390x x86_64):

permissions-20170707-6.4.1
permissions-debuginfo-20170707-6.4.1
permissions-debugsource-20170707-6.4.1


References:

https://www.suse.com/security/cve/CVE-2019-3688.html
https://www.suse.com/security/cve/CVE-2019-3690.html
https://www.suse.com/security/cve/CVE-2020-8013.html
https://bugzilla.suse.com/1047247
https://bugzilla.suse.com/1050467
https://bugzilla.suse.com/1093414
https://bugzilla.suse.com/1097665
https://bugzilla.suse.com/1123886
https://bugzilla.suse.com/1150734
https://bugzilla.suse.com/1155939
https://bugzilla.suse.com/1157198
https://bugzilla.suse.com/1160594
https://bugzilla.suse.com/1160764
https://bugzilla.suse.com/1161779
https://bugzilla.suse.com/1163922
https://bugzilla.suse.com/1171883
https://bugzilla.suse.com/1182899
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung