Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in vim
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in vim
ID: FEDORA-2022-a3d70b50f0
Distribution: Fedora
Plattformen: Fedora 35
Datum: Fr, 7. Januar 2022, 07:44
Referenzen: https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4136
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4187
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4173
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4186
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-4166
Applikationen: vim

Originalnachricht

-------------------------------------------------------------------------------
-
Fedora Update Notification
FEDORA-2022-a3d70b50f0
2022-01-07 01:15:51.498774
-------------------------------------------------------------------------------
-

Name : vim
Product : Fedora 35
Version : 8.2.4006
Release : 1.fc35
URL : http://www.vim.org/
Summary : The VIM editor
Description :
VIM (VIsual editor iMproved) is an updated and improved version of the
vi editor. Vi was the first real screen-based editor for UNIX, and is
still very popular. VIM improves on vi by adding new features:
multiple windows, multi-level undo, block highlighting and more.

-------------------------------------------------------------------------------
-
Update Information:

Security fix for CVE-2021-4136, CVE-2021-4166, CVE-2021-4173, CVE-2021-4186
-------------------------------------------------------------------------------
-
ChangeLog:

* Wed Jan 5 2022 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.2.4006-1
- patchlevel 4006
* Wed Dec 15 2021 Zdenek Dohnal <zdohnal@redhat.com> - 2:8.2.3811-1
- patchlevel 3811
-------------------------------------------------------------------------------
-
References:

[ 1 ] Bug #2034720 - CVE-2021-4136 vim: heap-based buffer overflow in
eval_lambda() in src/eval.c
https://bugzilla.redhat.com/show_bug.cgi?id=2034720
[ 2 ] Bug #2035928 - CVE-2021-4166 vim: out-of-bounds read in do_arg_all() in
src/arglist.c
https://bugzilla.redhat.com/show_bug.cgi?id=2035928
[ 3 ] Bug #2035930 - CVE-2021-4173 vim: use-after-free with nested :def
function
https://bugzilla.redhat.com/show_bug.cgi?id=2035930
[ 4 ] Bug #2036129 - CVE-2021-4187 vim: use-after-free vulnerability
https://bugzilla.redhat.com/show_bug.cgi?id=2036129
-------------------------------------------------------------------------------
-

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2022-a3d70b50f0' at the command
line. For more information, refer to the dnf documentation available at
http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
-------------------------------------------------------------------------------
-
_______________________________________________
package-announce mailing list -- package-announce@lists.fedoraproject.org
To unsubscribe send an email to package-announce-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org
Do not reply to spam on the list, report it: https://pagure.io/fedora-infrastructure
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung