Login
Newsletter
Werbung

Sicherheit: Pufferüberlauf in Mod_auth_kerb
Aktuelle Meldungen Distributionen
Name: Pufferüberlauf in Mod_auth_kerb
ID: 200701-14
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Di, 23. Januar 2007, 00:11
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-5989
Applikationen: Mod_auth_kerb

Originalnachricht


--uTRFFR9qmiCqR05s
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200701-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: Mod_auth_kerb: Denial of Service
Date: January 22, 2007
Bugs: #155782
ID: 200701-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Mod_auth_kerb is vulnerable to a buffer overflow possibly allowing a
Denial of Service.

Background
==========

Mod_auth_kerb is an Apache authentication module using Kerberos.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-www/mod_auth_kerb < 5.0_rc7-r1 >= 5.0_rc7-r1

Description
===========

Mod_auth_kerb improperly handles component byte encoding in the
der_get_oid() function, allowing for a buffer overflow to occur if
there are no components which require more than one byte for encoding.

Impact
======

An attacker could try to access a Kerberos protected resource on an
Apache server with an incorrectly configured service principal and
crash the server process. It is important to note that this buffer
overflow is not known to allow for the execution of code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All mod_auth_kerb users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose
">=net-www/mod_auth_kerb-5.0_rc7-r1"

References
==========

[ 1 ] CVE-2006-5989
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-5989

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200701-14.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--uTRFFR9qmiCqR05s
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iQEVAwUBRbU8PjvRww8BFPxFAQI2fQgAnf2MHZLbu4TWbZszXjYv5PKpK96IIOWS
vIQrQCnnSDoCmQ17diNhtlvRT6+6rWrfRy+sn3iagOfa/zEsj17bPedrEGfDgPXU
hmU85lwIndjYh+j7t4onOXLYUHl+Cg5Eo2EPjZDhh528tIgiFRAn2mNa0++SAJ7E
YPGLbZ724ldu/ITMS9QJZhRa0NCz4rSIuirJtfy5AaPGl9/j8vtqzPmPTCng8jfk
qh2/Xyd89IYpcoLMcwh5mDY6p31biOSylwcfvi0amDKqM3tkn48dWnkFN4eClmc+
QQglPPl2lFkGQ4T8wA4jGK+myhZbRExQlKjcxLWSJLmgFdNL5lT+DA==
=OqCB
-----END PGP SIGNATURE-----

--uTRFFR9qmiCqR05s--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Traut euch!
Neue Nachrichten
Werbung