Login
Newsletter
Werbung

Sicherheit: Ausführen beliebiger Kommandos in PostgreSQL
Aktuelle Meldungen Distributionen
Name: Ausführen beliebiger Kommandos in PostgreSQL
ID: 200705-12
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Do, 10. Mai 2007, 20:48
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2138
Applikationen: PostgreSQL

Originalnachricht

--nextPart1412236.41TH07Kd4m
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200705-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: PostgreSQL: Privilege escalation
Date: May 10, 2007
Bugs: #175791
ID: 200705-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

PostgreSQL contains a vulnerability that could result in SQL privilege
escalation.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 dev-db/postgresql < 8.0.13 >= 8.0.13
*>= 7.4.17
*>= 7.3.19

Description
===========

An error involving insecure search_path settings in the SECURITY
DEFINER functions has been reported in PostgreSQL.

Impact
======

If allowed to call a SECURITY DEFINER function, an attacker could gain
the SQL privileges of the owner of the called function.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL users should upgrade to the latest version and fix their
SECURITY DEFINER functions:

# emerge --sync
# emerge --ask --oneshot --verbose "dev-db/postgresql"

In order to fix the SECURITY DEFINER functions, PostgreSQL users are
advised to refer to the PostgreSQL documentation:
http://www.postgresql.org/docs/techdocs.77

References
==========

[ 1 ] CVE-2007-2138
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2138

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200705-12.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--nextPart1412236.41TH07Kd4m
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQBGQ2d1zKC5hMHO6rkRAkJMAJ46IqLRTgIPQ6LNx2zIqsGfdJxzgACdF6IS
OBWh91oYgDsvU+CIUxctUZc=
=A3eE
-----END PGP SIGNATURE-----

--nextPart1412236.41TH07Kd4m--
--
gentoo-announce@gentoo.org mailing list
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung