Login
Newsletter
Werbung

Sicherheit: Mehrere Probleme in OpenShift
Aktuelle Meldungen Distributionen
Name: Mehrere Probleme in OpenShift
ID: RHSA-2022:6681-01
Distribution: Red Hat
Plattformen: Red Hat cnv
Datum: Do, 22. September 2022, 21:51
Referenzen: https://access.redhat.com/security/cve/CVE-2022-1798
https://access.redhat.com/security/cve/CVE-2022-2526
https://access.redhat.com/security/cve/CVE-2022-0494
https://access.redhat.com/security/cve/CVE-2022-1271
https://access.redhat.com/security/cve/CVE-2022-29154
https://access.redhat.com/security/cve/CVE-2022-1353
Applikationen: OKD

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Important: OpenShift Virtualization 4.9.6 Images security
and bug fix update
Advisory ID: RHSA-2022:6681-01
Product: cnv
Advisory URL: https://access.redhat.com/errata/RHSA-2022:6681
Issue date: 2022-09-22
CVE Names: CVE-2022-0494 CVE-2022-1271 CVE-2022-1353
CVE-2022-1798 CVE-2022-2526 CVE-2022-29154
=====================================================================

1. Summary:

Red Hat OpenShift Virtualization release 4.9.6 is now available with
updates to packages and images that fix several bugs and add enhancements.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Description:

This advisory contains the following OpenShift Virtualization 4.9.6 images:

RHEL-8-CNV-4.9
==============
cnv-must-gather-container-v4.9.6-7
kubevirt-template-validator-container-v4.9.6-6
kubevirt-ssp-operator-container-v4.9.6-5
virt-cdi-uploadserver-container-v4.9.6-4
virt-cdi-cloner-container-v4.9.6-4
virt-cdi-importer-container-v4.9.6-4
virt-cdi-uploadproxy-container-v4.9.6-4
virt-cdi-apiserver-container-v4.9.6-4
virt-cdi-controller-container-v4.9.6-4
virt-cdi-operator-container-v4.9.6-4
hostpath-provisioner-container-v4.9.6-3
hyperconverged-cluster-webhook-container-v4.9.6-3
hyperconverged-cluster-operator-container-v4.9.6-3
node-maintenance-operator-container-v4.9.6-4
kubevirt-vmware-container-v4.9.6-3
kubevirt-v2v-conversion-container-v4.9.6-3
ovs-cni-plugin-container-v4.9.6-3
cnv-containernetworking-plugins-container-v4.9.6-3
bridge-marker-container-v4.9.6-4
ovs-cni-marker-container-v4.9.6-3
kubemacpool-container-v4.9.6-4
kubernetes-nmstate-handler-container-v4.9.6-5
cluster-network-addons-operator-container-v4.9.6-5
virt-controller-container-v4.9.6-9
virt-handler-container-v4.9.6-9
virt-api-container-v4.9.6-9
virt-operator-container-v4.9.6-9
virt-artifacts-server-container-v4.9.6-9
virt-launcher-container-v4.9.6-9
libguestfs-tools-container-v4.9.6-9
virtio-win-container-v4.9.6-3
hostpath-provisioner-operator-container-v4.9.6-3
vm-import-operator-container-v4.9.6-3
vm-import-controller-container-v4.9.6-3
vm-import-virtv2v-container-v4.9.6-3
hco-bundle-registry-container-v4.9.6-51

Security Fix(es):

* kubeVirt: Arbitrary file read on the host from KubeVirt VMs
(CVE-2022-1798)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

3. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

4. Bugs fixed (https://bugzilla.redhat.com/):

2092269 - We cant migrate to newer target node and than return to the source
node when using host-model cpu
2097313 - RHEL9 templates missing UEFI params
2101174 - [4.9.z]VM restore PVC uses exact source PVC request size
2110783 - 4.8 to 4.9 upgrade path blocked due to bug in NMState pods
2117872 - CVE-2022-1798 kubeVirt: Arbitrary file read on the host from KubeVirt
VMs
2118317 - KubeVirtComponentExceedsRequestedMemory Prometheus Rule is Failing to
Evaluate

5. References:

https://access.redhat.com/security/cve/CVE-2022-0494
https://access.redhat.com/security/cve/CVE-2022-1271
https://access.redhat.com/security/cve/CVE-2022-1353
https://access.redhat.com/security/cve/CVE-2022-1798
https://access.redhat.com/security/cve/CVE-2022-2526
https://access.redhat.com/security/cve/CVE-2022-29154
https://access.redhat.com/security/updates/classification/#important

6. Contact:

The Red Hat security contact is <secalert@redhat.com>. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2022 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYyxZo9zjgjWX9erEAQjo2A/+NnlergXU1yY0jWMExEZNIE8AH8I6hJWV
XzvEuM30apynfJM52XQ4S9bhSftrYwBXNjBnIR8mEb4c9Lio+r9wl75dLl5sX6do
xxcRjBlqRYCK/s4+NRJHqSMo6rjoarHSUOGNlO0KpSRp3LW58AWWdOl39FAtMk5k
Xqw1DJEimnn/wiyMBFeqxbNAsmELD3/PttmsezxUfV2B4/PNVkgelnAd9WluNllo
FkE8sF2zhdRRzpaqYMsHKpsZVltlKDdRsGYSjJawlfa3F/WyLU/7aoRoW9hDwmt4
/5f5vynkfmknzgETfs4Gu0GJP3fMZCNJzFDH1mRxmR//XrcZdEcxsO2GIjyGaFj4
oStL9bJR4sv8xd8/9jRQ6qBZZPFeC3FRURTJ6jGmbsBcxjk/e+IXEoLbdzYbWljB
0DCEYXV+82nimw5lUTar5EfdpliaYKpZ7fl0mIb1kWq14DB6Hzhtk572iY8hwsrc
OApYEqXxZ6ma+hkfvtedtGeEKhrTu/LBeZO7UF3Jxa/qrW/4HY9x5g5FT7lH8PXN
VAG7yOyCrKtRbnSk9FG++sikQMEJXq/2VmCRxlTkWqHvpdcce8LqOrJ83ki20HPc
g49Ybn+YmjDHckDnhZ+sO/3P2rmzduzDw7DTZ2T7FjHlMO+0F5EhGZOj5qoM0piV
3FbAxpQJNuw=
=dWBS
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://listman.redhat.com/mailman/listinfo/rhsa-announce
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung