Login
Newsletter
Werbung

Sicherheit: Zahlenüberlauf in pdfkit.framework
Aktuelle Meldungen Distributionen
Name: Zahlenüberlauf in pdfkit.framework
ID: DSA-1352-1
Distribution: Debian
Plattformen: Debian sarge
Datum: Di, 7. August 2007, 23:48
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-3387
Applikationen: pdfkit.framework

Originalnachricht

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1352-1 security@debian.org
http://www.debian.org/security/ Moritz Muehlenhoff
August 7th, 2007 http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package : pdfkit.framework
Vulnerability : integer overflow
Problem type : local (remote)
Debian-specific: no
CVE ID : CVE-2007-3387

It was discovered that an integer overflow in the xpdf PDF viewer may lead
to the execution of arbitrary code if a malformed PDF file is opened.

pdfkit.framework includes a copy of the xpdf code and required an update
as well.

For the oldstable distribution (sarge) this problem has been fixed in
version 0.8-2sarge4.

The package from the stable distribution (etch) links dynamically
against libpoppler and doesn't require a separate update.

The package from the unstable distribution (sid) links dynamically
against libpoppler and doesn't require a separate update.

We recommend that you upgrade your pdfkit.framework packages.


Upgrade Instructions
- --------------------

wget url
will fetch the file for you
dpkg -i file.deb
will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given at the end of this advisory:

apt-get update
will update the internal database
apt-get upgrade
will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

Source archives:

pdfkit.framework_0.8-2sarge4.dsc
Size/MD5 checksum: 725 bfe8bf57eeadaeeaa5ba33a458a8e185
pdfkit.framework_0.8-2sarge4.diff.gz
Size/MD5 checksum: 7077 a9e6dc46fa95a2763e865999b3789e50
pdfkit.framework_0.8.orig.tar.gz
Size/MD5 checksum: 1780533 7676643ff78a0602c10bfb97fe0bd448

Alpha architecture:

pdfkit.framework_0.8-2sarge4_alpha.deb
Size/MD5 checksum: 1822590 0f097258e91f1d7eabf3384ecb10b3e8

AMD64 architecture:

pdfkit.framework_0.8-2sarge4_amd64.deb
Size/MD5 checksum: 1797204 534d18691bdd0729af9e854311408460

HP Precision architecture:

pdfkit.framework_0.8-2sarge4_hppa.deb
Size/MD5 checksum: 1863092 764d3796d34c879af9a5594c4f50e5e9

Intel IA-32 architecture:

pdfkit.framework_0.8-2sarge4_i386.deb
Size/MD5 checksum: 1750926 fd435c2d7270d324c74aa054c7230e96

Intel IA-64 architecture:

pdfkit.framework_0.8-2sarge4_ia64.deb
Size/MD5 checksum: 1981838 c7a18c58ea887fb5b0f2194659ccdd77

Motorola 680x0 architecture:

pdfkit.framework_0.8-2sarge4_m68k.deb
Size/MD5 checksum: 1786348 3b4885f47d0d55dad0e70aa20e42c73d

Big endian MIPS architecture:

pdfkit.framework_0.8-2sarge4_mips.deb
Size/MD5 checksum: 1769560 9f0071e086fa239f2068d426f9dddae9

Little endian MIPS architecture:

pdfkit.framework_0.8-2sarge4_mipsel.deb
Size/MD5 checksum: 1755228 cda830fc73806bc80e1104359fea752a

PowerPC architecture:

pdfkit.framework_0.8-2sarge4_powerpc.deb
Size/MD5 checksum: 1771430 1d2fb8df07e688855b1c716123c2213d

IBM S/390 architecture:

pdfkit.framework_0.8-2sarge4_s390.deb
Size/MD5 checksum: 1805290 78cfaa378a73eae337978d3df379be99

Sun Sparc architecture:

pdfkit.framework_0.8-2sarge4_sparc.deb
Size/MD5 checksum: 1780538 cb9824fd6a64b10257f79d0df7c1a474


These files will probably be moved into the stable distribution on
its next update.

-
---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-securitydists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGuOMmXm3vHE4uyloRAqTUAJ9s+zyZlOD5c5TmSQAtY+/kkyKPcACg5jKg
Tggz0EX0aPmHlU+n6TIr8bg=
=Qsur
-----END PGP SIGNATURE-----


--
To UNSUBSCRIBE, email to debian-security-announce-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact
listmaster@lists.debian.org
Pro-Linux
Gewinnspiel
Neue Nachrichten
Werbung