Login
Newsletter
Werbung

Sicherheit: Denial of Service in MaraDNS
Aktuelle Meldungen Distributionen
Name: Denial of Service in MaraDNS
ID: 200801-16
Distribution: Gentoo
Plattformen: Keine Angabe
Datum: Mi, 30. Januar 2008, 00:08
Referenzen: http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0061
Applikationen: MaraDNS

Originalnachricht


--EP0wieDxd4TSJjHq
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 200801-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal
Title: MaraDNS: CNAME Denial of Service
Date: January 29, 2008
Bugs: #204351
ID: 200801-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

MaraDNS is prone to a Denial of Service vulnerability impacting CNAME
resolution.

Background
==========

MaraDNS is a package that implements the Domain Name Service (DNS) with
resolver and caching ability.

Affected packages
=================

-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 net-dns/maradns < 1.2.12.08 >= 1.2.12.08

Description
===========

Michael Krieger reported that a specially crafted DNS could prevent an
authoritative canonical name (CNAME) record from being resolved because
of an "improper rotation of resource records".

Impact
======

A remote attacker could send specially crafted DNS packets to a
vulnerable server, making it unable to resolve CNAME records.

Workaround
==========

Add "max_ar_chain = 2" to the "marac" configuration file.

Resolution
==========

All MaraDNS users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=net-dns/maradns-1.2.12.09"

References
==========

[ 1 ] CVE-2008-0061
http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2008-0061

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200801-16.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5

--EP0wieDxd4TSJjHq
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)

iQEVAwUBR5+vmzvRww8BFPxFAQKd3AgAjZ1YfJYCsvi/hDb+5Ay5FLhZsCBoj0zf
wQ+SJaAjY33oe/GWO3CL/akkiY1WI+F49L20C1410JLELDInY/X4PJ03HSFm+BGN
CTyGJ7pQd06RwAaaa/wLXqDBdsekm3MbF5c3T4UF0vDXriVDw9MSslTpP+AIRwJ+
GOgT7NhOpJhhVc1czfurTu4ahfayI70QpD9ZuuDu2TRlseqqGPz9b5LFJwPOl4H7
4vUSgAp75hPfpV2MTzyz/C0ITBhlK1//s1B/IIZErtvQTcWDuAUtnulLI/KzJVsm
J4ub6Oqe3BmkMXnhuQVMJknGUA1Fv+dWf2xoaMEuffQZ99jXIkBh4w==
=YiWm
-----END PGP SIGNATURE-----

--EP0wieDxd4TSJjHq--
--
gentoo-announce@lists.gentoo.org mailing list
Pro-Linux
Pro-Linux @Facebook
Neue Nachrichten
Werbung